Re: [orca-list] Gnome3, Orca and ArchLinux

The thing I am on about, it really doesn't get seen by orca, you will not even hear icon.

The best way I have found to get at it is to press ctrl+alt+tab to get to the top panel, tab until you hear menu, now try some cursoring left and right and try up and down in different places and it will appear. Be careful as you may end up in the applications or places menu as well and once in those you are captive until you press escape to exit those menus.

This really is hit and miss from what I have experienced.

Considering the state of gnome 3, this menu thing, the lack of the desktop, I have actually chosen to use XFCE more. In XFCE the desktop icons may not be spoken by orca (that is an accessibility issues but the icons are there and keyboard navigable), ctrl+esc will get the menu and you can access logout/shutdown/restart (choose the logout menu item the shutdown options are in the dialog which appears). I have not found how to access tray icons, don't know whether that is another limitation or if I simply haven't discovered that.

LXDE also may be an option, however it feels more limited (less features). Also at the moment there is an issue with LXDE's filemanager pcmanfm, if starting LXDE from a login manager such as GDM X crashes, starting LXDE using startx does not suffer this issue.

Michael Whapples
On 05/05/11 20:01, Steve Holmes wrote:
I didn't see much additional stuff in the top panel when I looked
around there this morning.  I saw a couple icons which I had to use
Ctrl+F1 to identify but I didn't see any settings or system menu up
there.  I recall seeing a Universal Access menu (I thought I did) in
the Applications menu but II'll need to check this this evening when I
get home and have more time than I did this morning when I got Orca
talking atl least.  I also noticed the Applications and Places menus
are side by side again; I had gotten used to the linear view that came
with recent upgrades of gnome 2.32 or so; I rather liked that view

I am rather disappointed with Gnome 3 in the a11y department.  It
seems that a lot of stuff is broken now and the fact that I cannot get
to or find the system menu nor the desktop, is almost a show stopper.
I mean you need to access the system menu if you want to log out of
gnome or configure your system.  That's a major flaw in my book!

On 5/5/11, Michael Whapples<mwhapples aim com>  wrote:
On where the system menu has gone, some of the stuff can be found in
another menu (not sure if its in the tray). What you need to do is move
to the top panel, its somewhere in there. At this point I have not found
a reliable way of bringing it up but it can be got at from the keyboard.

Now about orca starting automatically, in that menu mentioned above
there is an option for settings (or something like that), go to that and
then find universal access in the screen which appears. In that settings
screen you will find a setting to enable orca being started on log in.

Haven't got a clue about the desktop.

Some of these issues are why I have tried out XFCE and LXDE, which are
sort of usable but still have issues of their own (eg. XFCE's desktop
isn't being spoken by orca, the panels aren't fully accessible as you
cannot look in their trays, etc).

Michael Whapples
On 01/-10/37 20:59, Steve Holmes wrote:
I think this script would be interesting to look at for sure.

Also, I got pulse working for gnome (sort of) and I still have the
good ol' console back talking all in the same session.  I commented
out all the entries in /etc/asound.conf and after a reboot, the sound
situation seems OK for me now.

Other issues though, Orca does not start up automatically; I had to
launch it with the run dialog but at least it talks now.  Oh, I also
had to install at-spi2-atk package before Orca would continue to
function so Orca is working now.

Now on to gnome3 itself, I also cannot find the system menu; nor can I
find the desktop.  Someone else commented these same observations
yesterday on the list but I haven't seen any replies to that issue.  I
can press Ctrl+Alt+tab to toggle between top and bottom pannel but no
desktop.  What's going on here?

On Thu, May 05, 2011 at 06:45:09AM -0500, Alex Midence wrote:
My greetings of the morning, Arch Linux folks:   =)

Reading this thread put me to thinking:  We've been using Pulse Audio
in Vinux since mid 2010.  Bill Cox worked out a way to get it to
behave and either he or Tony (not sure who) wrote a very nice script
which you all may find rather handy.  It's called restorespeech.  It
will undoubtedly require some modification to fit in with how Arch
does things but, I'll scare up my copy when I get home tonight and
e-mail to the list in hopes it helps someone.  What it does is modify
your Pulse Audio setup such that Speakup, Orca and Yasr behave like
good little programs and stop being bashful and talk without any of
that nasty latency and crackle Pulse is infamous for.  It'll set pulse
up for you, rebuild speakup from source, I think, install and
configure speech dispatcher, orca and yasr for you.  It's designed to
get your pc talking with just one command or even a hotkey since it's
also bound to control alt shift r in Gnome.  Very handy for when
updates break accessibility and you lose speech for some reason or
other and you are dead in the water because of it since, as you all
well know, you don't always have a nice sighted pal within shouting
distance to lend a hand.  Like I said, it will probably require some
modification and adaptation to conform with how Arch Linux does things
and, you may not need all of its functionality but it may be something
you find useful.  If you can't wait and want to get your hands on it,
google the vinux project's PPA and see if you can't download it by
downloading the Vinuxscripts package and rooting around in there till
you find it.

Alex M

On 5/4/11, Christian<christian08 runbox com>   wrote:
My sound has just stopped working here in Arch linux after I installed
is it because of Pulseaudio?
If so, how to get it back?
Many thanks,

On 2011-05-04 at 21:18 Michael Whapples wrote:

What I suggested allows you still to use an application directly with
alsa. I don't know whether gnome 3 can be made so it does not use
pulseaudio but the archlinux packages sure depend on pulseaudio. The
best I have found is to stop pulseaudio blocking the actual device and
allow you still to use alsa without going through pulse.

Michael Whapples
On 04/05/11 18:18, Storm Dragon wrote:
Is it absolutely necessary to use pulseaudio in Arch with gnome3? If
so I may stick with what I have already. It's nice to be able to play
audio games in wine without having the lag introduced by pulse.
Vinux Publicity Coordinator:
Registered Linux user number 508465:
My blog, Thoughts of a Dragon:
How many Internet mail list subscribers does it take to change a
Vinux is Linux done right:
"Every day is Halloween"
Type O Negative

On Wed, 2011-05-04 at 18:02 +0100, Michael Whapples wrote:
If all speech output on your system was affected then it sounds like
might be another pulseaudio issue. I have been able to get a
satisfactory set up now on my laptop which uses pulseaudio (thank you
Halim), although I still feel pulseaudio is over complicating things.

Halim posted a example to the list, put that somewhere
pulseaudio will find it (I put it in /etc/pulse/, although
aware that is system wide and user settings may override it, a
problem I
hit). Now archlinux also provides a asound.conf file to configure
applications to use pulseaudio's emulation, comment out the content
this file as we want alsa applications to access alsa directly.
Configure speech-dispatcher to use alsa (NOTE: I have had issues
speech-dispatcher has not worked properly with pulseaudio, if you
to use speech-dispatcher with pulseaudio I would recommend using it
through libao). Now restart the system (I recommend restarting as it
ensures everything has actually been stopped and reloads

If you still have issues there is one thing which may be wrong: As I
mentioned if you put in the /etc/pulse directory user
settings may override this, I had an issue where my GDM user had the
default device pulseaudio would use was the actual hardware and so
the device), in this case check your settings (look at files in
~/.pulse) in any user where sound isn't working properly.

I hope this works, it did for me.

Michael Whapples
On 01/-10/37 20:59, Steve Holmes wrote:
   Hey, I just decided to try and fire up gnome after all the Arch
   packages updated to gnome 3.  I also pulled out orca-git for now
so I
   could establish a base line by using orca-3.01 from the Arch repo.

   When I installed Orca package, it also brought in at-spi2 and
   as dependencies.  But when I do 'startx' gnome starts up but I get
   sound at all! I then thought I would tryh to force Orca to start
   by running from the run dialog and I got "Welcome to Orca" spoken
   nothing after that.  then I discovered that I lost all speech -
   on the console.  I had to reboot to get at least, back to a

   Are there suggestions on what else I need to do to get gnome3 +
   working properly? I recall directions on the Arch wiki for gnome 3
   I would think that wouldn't be necessary anymore since gnome3 is
   the current default.

   Any help?

orca-list mailing list
orca-list gnome org<mailto:orca-list gnome org>
Visit  for more information on Orca.
The manual is
The FAQ is at
Netiquette Guidelines are
Log bugs and feature requests at
Find out how to help at
orca-list mailing list
orca-list gnome org
Visit for more information on Orca.
The manual is at
The FAQ is at
Netiquette Guidelines are at
Log bugs and feature requests at
Find out how to help at

orca-list mailing list
orca-list gnome org
Visit for more information on Orca.
The manual is at
The FAQ is at
Netiquette Guidelines are at
Log bugs and feature requests at
Find out how to help at

orca-list mailing list
orca-list gnome org
Visit for more information on Orca.
The manual is at
The FAQ is at
Netiquette Guidelines are at
Log bugs and feature requests at
Find out how to help at
orca-list mailing list
orca-list gnome org
Visit for more information on Orca.
The manual is at
The FAQ is at
Netiquette Guidelines are at
Log bugs and feature requests at
Find out how to help at

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]