Re: [Evolution] Failing to connect to Office365 account with MFA

On Thu, 2021-09-02 at 10:29 +0200, Milan Crha via evolution-list wrote:
On Thu, 2021-09-02 at 10:19 +0200, Vincent Hennebert via evolution-list
I know nothing about OAuth2 except maybe the name but, is there any
more debug data I can provide from Evolution or DavMail that could
help pinpoint the issue?

Not from the evo side. I cannot speak about DavMail.

Could you try to create a new test user on the machine and create the
EWS  account for that user, please? That will do it from scratch, like
it had been never configured on the machine.

So I’ve just tried, and same error.

As I said before, exactly the same steps you use work for me fine, on
the same distro, with the same versions.

but I found that I could just ignore it by pressing Escape and
Evolution would proceed downloading my email and calendar event.

Evil is in the details. The window asking for the credentials tells for
what it needs it. At the top, in bold. The other text in the window can
be important too. I'd guess some of the sub-source(s) has got out of
sync with the authentication method, maybe. It's only a wild guess.

I dug a little bit more into the DavMail log. It does the same as Evo
until the <Back to different org SSO URL>. That URL briefly shows up in
Evo’s authentication window, then is replaced with ‘none-local://’ (not
sure what that is) and a message ‘Requesting access token, please
wait...’ (that one seems to be coming from Evo itself), and then the
error message. It looks like Evo is ignoring the content returned by
the last SSO URL, but of course I may be wrong.

When it loads that last SSO URL, DavMail shows another page that says
‘Working...’ with that form I mentioned earlier that posts to After that I see a
connection to

Does that make any sense?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]