Re: [Evolution] Failing to connect to Office365 account with MFA

On Tue, 2021-08-31 at 18:32 +0200, Vincent Hennebert via evolution-list
None of those worked :( Every time the OAuth window shows up, I enter
my credentials, confirm the login from my phone’s app, and then get the
same error.

I know those keys work fine, not only for me, thus the problem is
somewhere else.

Your second message in this thread contains a snippet of the OAuth2
debug log, but not enough of it. I'd need to see what had been sent to
the server, which resulted into the Bad Request response. The base64
encoded things and the application and other IDs should be replaced,
similarly as you did before.

What values do you change in the OAuth2 settings of the Office 365
account? Most of the values should be left empty, it's usually enough
to change/set the Application ID and left the rest empty.

I think I saw similar error when I changed the Tenant ID to something
else, when I did not left it to its default value, which is "common". I
do not know how that works for your company though, due to the multi-
factor login.

I'd guess the settings you use for the DAVMail are not exactly the same
as for the Evolution-EWS. The only other thing might be the resource
URI. It's currently derived from the Host Name, while it used to be
""; in the past. I understood from your
messages that you did not update the evolution-ews, it's still the same
version, you only changed the password on the server.

I cannot think of anything else right now, I'm sorry.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]