Re: [Evolution] Failing to connect to Office365 account with MFA

On Wed, 2021-09-01 at 18:46 +0200, Vincent Hennebert via evolution-list
I thought the first 2 warnings might have been associated with my
other email accounts but actually not, I temporarily disabled them.


if I'm not mistaken then the Single-Sign-On (SSO) page your company
provides supports also the Kerberos (GSSAPI) login, which could not be
used here (the error says), even it had been tried. In other words,
having configured Kerberos on the machine and the tickets granted with
the `kinit` you may not need to enter the credentials into the SSO
page. If I'm not wrong. There are surely companies, where the the SSO
works this way.

I’ve just tried again leaving the Tenant ID empty and I get the same

Does the log confirm the 'common' tenant is used in this case? The
`evolution --force-shutdown` may make sure the things will work as
expected in all the processes (though it should not be needed to call).

You mentioned Flatpak. Things work differently there, especially the
--force-shutdown. The accounts are defined separately as well, they are
not shared with the host system. Thus if you change anything in the
account settings in the Flatpak Evolution, it's not propagated into the
host system settings and vice versa. As long as you can get the latest
code in the distribution, I suggest to use that. The Flatpak is good
for distros where it's not possible, for its price.

Note when you have both installed it's most likely when you run
Evolution from the GUI it'll start the Flatpak version. You can verify
that in the Help->About. Running `ps ax | grep evolution` will show you
all the evolution (and evolution-data-server) related processes
currently running. Those from "/app/" are from the Flatpak. Flatpak
suffers also with a libsecret bug, which prevents things to work

See the screenshot there, "OAuth2 secret not found" is the reason, why
the dialog opened.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]