Re: [Evolution] Why does not copy & paste work in separate monitor setup?

On Wed, 2015-07-15 at 19:33 +0200, Bjørn T Johansen wrote:

On Wed, 15 Jul 2015 16:04:21 +0100
Pete Biggs <pete biggs org uk> wrote:

I thought that it did since my statement negates that I am running X 
that is spanning my desktop across two screens... But to clarify, I have 
one monitor at $DISPLAY :0.0 and one at $DISPLAY at :0.1.

OK, so you are running a single X server controlling two screens
(multiple X servers would be called :0.0, :1.0, etc.).  These
distinctions are subtle but important.

Aaah, did not know that... I guess that multiple X servers come into play with
two graphics cards then?

What I suggest you do is to install some form of clipboard manager -
clipit, parcellite, etc. - and then you can see what's actually being
cut and where the problem is.

Ok, tried both and they both worked a couple times at first and then the paste
stopped working again... I can see the text I copied in those
applications but they are just not there when I try to paste on the other
screen... (btw, it is the same when I try to paste something into Evolution
from the other screen).

btw, I am using Nvidia drivers version 352.21-2 (it that's of any interest...)


evolution-list mailing list
evolution-list gnome org
To change your list options or unsubscribe, visit ...

i'm using two monitors + laptop lcd ( 3 total ) with parcellite and

NVIDIA settings gui lists driver version at 352.21 as does gentoo

parcellite has worked w/o issue for me.  I have also tried copyq and it
seemed to work fine.

lightdm + openbox3

i have a startup script that determines whether i'm currently running 3
screens or not and makes settings appropriately

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "HDMI-0: 1920x1080 +0+0, DVI-I-1: 1920x1080 +3840+0, DP-1: 1920x1080 +1920+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24

cat lightdm.conf

$ cat /home/rthompso/.screenlayout/
monitors=`xrandr | grep " connected " | wc -l`
if [ $monitors != 3 ]; then
    xrandr --output DVI-I-0 --off --output HDMI-0 --off --output DVI-I-1 --off --output DP-2 --off --output 
DP-1 --mode 1920x1080 --pos 0x0 --rotate normal --output DP-0 --off
    echo "setting up 1 monitor using nvidia xorg.conf" > /tmp/screenbootmsg
#    xrandr --output DVI-I-0 --off --output HDMI-0 --mode 1920x1080 --pos 0x0 --rotate normal --output 
DVI-I-1 --mode 1920x1080 --pos 3840x0 --rotate normal --output DP-2 --off --output DP-1 --mode 1920x1080 
--pos 1920x0 --rotate normal --output DP-0 --off
#   use saved nvidia-setting .xorg.conf file
    echo "setting up 3 monitors using nvidia xorg.conf" > /tmp/screenbootmsg

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]