Re: To sawfish from metacity?

To anyone who has the time: :)

I've been compiling packages and have run into some roadblocks. While
trying to compile sawfish-1.6.2 after having compiled everything else I
thought I needed (that wasn't already installed when I installed gnome)
./ or ./configure (I forget which) exited complaining that
it couldn't find libXineRama. (I don't know if it's significant, but
there are no files on my system, and none for the packages available to
install, in which the "r" is capitalized.) I tried installing devel
packages from the Mandriva Control Center but ran into file conflicts.
So I deleted /usr/local with the intention of bypassing rpms and compiling
everything needed from scratch and started over. I was able to compile gdb
and gdbm without incident. Then I ran ./ for librep and just
before it exited to the command line it printed this:

libgmp:              yes
libgdbm:             yes
readline:            no
libffi:              no

I checked in the software management screen on Mandrake Control Center
and it showed I have libffi4-devel installed, but in checking the files
it generates I see libffi.a but not which I understand is
what is needed for linking (correct me if I'm wrong; I'm learning this
as I go). So I downloaded tar.gz packages for both libffi-devel and
readline and compiled them, then reran ./ for librep. This
time it printed:

libgmp:              yes
libgdbm:             yes
readline:            yes
libffi:              no

But when I look in /usr/local/lib I see libffi.a,,,, and I'm not sure what the problem is.
Scrolling back I see:

checking for LIBFFI... no
checking ffi.h usability... yes
checking ffi.h presence... yes
checking for ffi.h... yes
checking for library containing ffi_call... -lffi

which are the only references to libffi that I can find. Is the "no" on
the LIBFFI line significant? Hope I'm not being a pain, but if anyone can
tell me where I'm going wrong it would be appreciated. After I get librep
and then rep-gtk compiled I plan to try compiling sawfish-1.6.2 again.
Hopefully I can solve the problem with libXinerama this time.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]