Re: Timeschedule of 0.7 release and possible sponsoring

Hash: SHA1

Jeroen van de Nieuwenhof wrote:
> Op vrijdag 14-09-2007 om 19:13 uur [tijdzone +0200], schreef dragoran:
>> Jeroen van de Nieuwenhof wrote:
>>>> On Thu, 2007-09-13 at 18:15 +0200, Jeroen van de Nieuwenhof wrote:
>>>>>>> Today i'm at the university that uses these settings in
>>>>> wpa_supplicant:
>>>>>>> network={
>>>>>>>         ssid="university"
>>>>>>>         scan_ssid=1
>>>>>>>         key_mgmt=IEEE8021X
>>>>>>>         eap=PEAP
>>>>>>>         phase2="auth=MSCHAPV2"
>>>>>>>         identity="account university tld
>>>>>>> <mailto:account university tld>"
>>>>>>>         password="password"
>>>>>>> }
>>>>>>> I tried connecting to the network with NetworkManager 0.6.5 in Ubuntu
>>>>>>> Gutsy and i couldn't get a connection. Networkmanager just kept on
>>>>>>> circling without returning any green bulbs (in the applet). I've
>>>>>>> selected LEAP, filled in my username and password and then chose
>>>>>>> IEEE802.1.x. I also tried WPA-EAP, but that didn't work too.
>>>>>>> If it's true that this type of connection is supported by
>>>>> NetworkManager
>>>>>>> 0.6.5, then what am i doing wrong?
>>>>>> You have to select WPA ENTERPRISE than PEAP , Dynamic WEP and MSCHAPV2
>>>>>> than it should work. Its not a LEAP network.
>>>>> This works for the first network. Now at my second university i have
>>>>> this
>>>>> wpa-supplicant config. I can't figure out how to get this working with
>>>>> NetworkManager.
>>>>> ctrl_interface=/var/run/wpa_supplicant
>>>>> eapol_version=1
>>>>> network={
>>>>>         ssid="ssid"
>>>>>         scan_ssid=1
>>>>>         key_mgmt=IEEE8021X
>>>>>         eap=TTLS
>>>>>         anonymous_identity="anonymous uni nl"
>>>>>         phase2="auth=PAP"
>>>>>         identity="account uni nl"
>>>>>         password="password"
>>>>>         ca_cert="/home/jeroen/Desktop/SURFnet-PCA-Root-CA.crt"
>>>>> }
>>>>> I selected WPA Enterprise TTLS, PAP, filled in the account settings and
>>>>> made a link to the certificate file in the CA field. What am i doing
>>>>> wrong, or is it even possible to connect to this network with
>>>>> NetworkManager?
>>>> This is dynamic WEP.  Use WPA Enterprise, and change the Key Type to
>>>> "Dynamic WEP".  Yes, it's odd, and yes, we'd like to make the WPA
>>>> options more understandable.
>>>> Dan
>>> This is great! Both the networks i tried work with NetworkManager. This is
>>> a pretty big step for Wifi users i think. Especially those who aren't
>>> familiar with command line and wpa-supplicant tweaking.
>>> I still have one question though: the networks with TTLS and PEAP are both
>>> recognised by networkmanager, but when i try to connect to them by
>>> clicking on them, i dont get the option for wpa enterprise. I have to
>>> manually connect to the networks to make the connection work. Is this a
>>> bug and do i have to file this bug, or is it a well known problem?
>>> Keep up the great work!
>> there is no way for nm to find out if its a wep dynamic network or not.
>> so you have to tell nm this info.
> I don't think you understand my question. I know NM can fill in all the
> details about the network. But right now i have to choose for 'Connect
> to other network' to plug in to the wireless network that uses Dynamic
> WEP because i don't get the wpa enterprise option when i click the
> network from the list of networks that NM has found. The option 'Connect
> to other Network' is only for connecting to networks with invissible
> essid's right?

I can echo this one with KNetworkManager. The most infuriating time is
when it detects a former network (such as on boot), and attempts to
reconnect to it. The screen appears asking for more information, but
WPA-Personal and WPA-Enterprise are missing from the screen where one
types in the information (it otherwise is identical to the screen that
appears when you click "Connect to other wireless network."

- --
 ---- _  _ _  _ ___  _  _  _
 |Y#| |  | |\/| |  \ |\ |  | |Ryan Novosielski - Systems Programmer II
 |$&| |__| |  | |__/ | \| _| |novosirj umdnj edu - 973/972.0922 (2-0922)
 \__/ Univ. of Med. and Dent.|IST/AST - NJMS Medical Science Bldg - C630
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla -

fn:Ryan Novosielski
adr;dom:MSB C630;;185 South Orange Avenue;Newark;NJ;07103
email;internet:novosirj umdnj edu
title:Systems Programmer III
tel;work:(973) 972-0922
tel;fax:(973) 972-7412
tel;pager:(866) 20-UMDNJ

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]