Re: [Evolution] Trash and Compose wierdness !? -[SOLVED -- I hope]

Hello William,

I had a similar problem. Since Fedora 9 I was having problems expunging
my whole Inbox (it was 900 MB or something). I was hopeful an upgrade to
Fedora 10 would fix my problem. It did not. Over the course of several
months, I had thousands of e-mails accumulate that could not be
expunged. In evolution, I would expunge the box, it would work for
several months and then tell me the expunge failed.

I solved the problem finally by firing up mutt (a text based mail
program). I decided to split my Inbox into 2009 e-mails and everything
else. I did this in evolution using the mail copy feature.  

With a clear strategy for reducing the number of e-mails in my working
Inbox (I deleted all e-mail older than 2009 in my working Inbox). I
shutdown evolution and run mutt with my mailbox formatted Inbox file. It
was a matter of using the delete command 5,000 times or so in Mutt.
Luckily the mutt accelerator keys are easy to use and fast. 

Within 30 minutes or so, I had my Inbox ready to use for evolution again
and expunging works again.

Morale of the story, don't allow your working Inbox to grow too large.

William, in your case you might be able to use mutt (or something
similar) to strategically delete the persistent e-mail that can't be

Best of luck,

On Thu, 2009-08-13 at 15:22 -0400, William Case wrote:
Hi Peter;

On Thu, 2009-08-13 at 15:11 +0100, Pete Biggs wrote:

For what it is worth, the end of time period for emails that won't
expunge corresponds (roughly) to my virgin install of Fedora 11 and
Evolution.  I think somehow Evo's restore function messed up at that

I did a clean install of F11, but I have separate /home partition and it
coped fine with everything.  Perhaps there's some difference between how
IMAP and POP is handled.

I usually use my /home partition as well.  But over several versions of
Fedora the cruft in /home had been building up so this time I backed
everything up to a separate hard disk and started clean,
including /home, on my Linux disk.

I used Evo File => Backup to store evo on my backup hard disk; after
installation I restored (Evo File => Restore) from the backup hard disk.

It should all work. I hadn't touched any of my Evo settings before or
since the new installation -- until a couple of days ago when I first
decided to try and fix the non-expunge problem.

I am getting really frustrated.

I can understand - but there will be something simple that's causing it,
the problem is finding it

No reply required.  I am just being a bit defensive.

An afterthought.  Could going from ext3 to ext4 on my new /home
partition have anything to do with it?

Rob Seward
Bluestone Consulting Group, LLC

e-mail:  rseward bluestone-consulting com
office:  734.274.5168
mobile:  734.604.3780

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]