Re: Bug 455400

Thanks, Thomas. Everything works now. I'm going to make my changes this afternoon (I'm in Seattle, USA -- Pacific time). So I should able to upload the patch file later today. I'll add more notes to the bug indicating the different places where I've made changes and additions. Mark

On 7/31/07, Thomas Harding <thomas harding laposte net> wrote:
On Tue, Jul 31, 2007 at 10:17:57AM -0700, Mark Dexter wrote:
> Hi Thomas. I have hit a small problem. When I applied the patch ("patch -p0
> < diff-doc-en.diff"), I think it was supposed to create a file called
> dia-cmdline.xml. However, it did not create this file. So now I get an error
> when I run the xsltproc command on my system. It appears to have modified
> the other xml files correctly, but did not create the dia-cmdline.xml file.
> Any ideas as to what I need to do? Thanks. Mark

Thats my fault: dia-cmdline.xml is created on-the-fly at compile time
from dia.dbk.

To cope with this if you don't plan to compile the whole dia dist,
simply run

"sed -f dia-dbk-to-chapter.sed <dia.dbk >dia-cmdline.xml"

Maybe it will be better I include that also in hardcopies.makefile :)
Thomas Harding
Dia-list mailing list
Dia-list gnome org
FAQ at
Main page at

Mark Dexter

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]