Re: very basic script broken?

k04jg02 kzoo edu (2008-07-26 at 1057.58 -0400):
> I have a ~/.sawfish/rc file that only contains this:
> (require 'sawmill-defaults)
> (require 'jump-or-exec)
> (bind-keys global-keymap
>   "H-f" `(jump-or-exec "Firefox"
>       ,(lambda ()
>          (system
>           "firefox &"))
>       ,(lambda (wind)
>          (display-window wind))))
> But when I press windows key + F nothing happens. I opened sawfish-ui  
> and tried binding something by pressing the windows key and f and sure  
> enough the string it used was "H-f" so know that part is right. I don't  
> get any console errors, and jump-or-exec.jl is in ~/.sawfish. I've also  
> tried executing the bind-keys sexp from within emacs while sawfish was  
> running, but I still get no errors and it still doesn't work. Any ideas?  
> How do you debug sawfish scripts?

Try putting it in ~/.sawfish/lisp/ or any other dir in load-path
var. You will also adding a line saying "(require 'jump-or-exec)" in
your config file ~/.sawfish/rc.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]