Re: very basic script broken?

Am Samstag, den 26.07.2008, 10:57 -0400 schrieb Joseph Garvin:
I have a ~/.sawfish/rc file that only contains this:

(require 'sawmill-defaults)
(require 'jump-or-exec)

(bind-keys global-keymap
   "H-f" `(jump-or-exec "Firefox"
       ,(lambda ()
           "firefox &"))
       ,(lambda (wind)
          (display-window wind))))

But when I press windows key + F nothing happens. I opened sawfish-ui 
and tried binding something by pressing the windows key and f and sure 
enough the string it used was "H-f" so know that part is right. I don't 
get any console errors, and jump-or-exec.jl is in ~/.sawfish. I've also 
tried executing the bind-keys sexp from within emacs while sawfish was 
running, but I still get no errors and it still doesn't work. Any ideas? 
How do you debug sawfish scripts?

try ~/.sawfishrc instead:

mv ~/.sawfish/rc ~/.sawfishrc

GNOME/Sawfish rule!

Attachment: signature.asc
Description: Dies ist ein digital signierter Nachrichtenteil

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]