Re: little bit off topic CLAT-Daemon for 464xlat for "Linux" (not android)

Tore Anderson <tore fud no> writes:
* Bjørn Mork

bjorn nemi:~$ mmcli -b 0
Bearer '/org/freedesktop/ModemManager1/Bearer/0'
  Status             |   connected: 'yes'
                     |   suspended: 'no'
                     |   interface: 'wwan0'
                     |  IP timeout: '20'
  Properties         |         apn: 'telenor.ipv6'
                     |     roaming: 'allowed'
                     |     IP type: 'ipv6'
                     |        user: 'none'
                     |    password: 'none'
                     |      number: 'none'
                     | Rm protocol: 'unknown'
  IPv4 configuration |   method: 'unknown'
  IPv6 configuration |   method: 'static'
                   |  address: '2a02:2121:1:8d03:1071:2644:9af8:1353'
                   |   prefix: '64'
                   |  gateway: '2a02:2121:1:8d03:b8aa:bdb9:24af:f588'
                   |      DNS: '2001:4600:4:fff::54', '2001:4600:4:1fff::54'

bjorn nemi:~$ ifconfig wwan0
wwan0     Link encap:Ethernet  HWaddr f6:6f:09:a5:cc:39  
          inet6 addr: fe80::f46f:9ff:fea5:cc39/64 Scope:Link
          inet6 addr: 2a02:2121:1:8d03:f46f:9ff:fea5:cc39/64 Scope:Global
          RX packets:15750 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10439 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:17693802 (16.8 MiB)  TX bytes:2424185 (2.3 MiB)

Hmm, interesting. Is there some support for IPv6 on mobile broadband in
NM nowadays?

I believe Dan just added such support. But I don't use NM at the
moment.  I do:

 mmcli -m 0 --simple-connect=apn=telenor.ipv6,ip-type=ipv6
 ip link set wwan0 up

relying on RAs from the modem to configure the address.

On my Fedora 20, there is no «IPv6» tab in
nm-connetion-editor for mobile broadband connection profiles like there
is for e.g. WiFi. Also I find it curious that ModemManager knows
anything about Layer 3, as I thought that would be NetworkManager's job.
Hmmm! I'll have to fiddle around more with this I think...

bjorn nemi:~$ ip -6 route
2a02:2121:1:8d03::c1a7 dev clat  metric 1024 
2a02:2121:1:8d03::/64 dev wwan0  proto kernel  metric 256 

Also this I find interesting. I first tried setting up TAYGA on my
desktop connected to an Ethernet segment with routing looking pretty
much like yours, but I ran into a problem - my CPE would do ICMPv6 NS
for the ::c1a7 address, not getting any NA responses because that
address isn't found anywhere on the Ethernet link.

ND proxy?  Or maybe adding the address to both interfaces will work?

Is the fact that it works for you on Ethernet some artifact of the
Ethernet implementation in the WWAN module being bastardised in some way
causing it to blindly forward everything in the /64 to the fake MAC
address f6:6f:09:a5:cc:39, or did you manage make the Linux IPv6 stack
respond to NS for the ::c1a7 address, or convince the WWAN module to
send packets to ::c1a7 to f6:6f:09:a5:cc:39 in some other way?

If it's blindly forwarding everything to your computer, does that mean
that bridging wwan0 with e.g. wlan0 (to make a wireless hotspot, say)
won't work?

Yes, this is blind forwarding. Note the NOARP flag on the interface. The
modem connection is MBIM, so there aren't any L2 headers to play with.
All the ethernet stuff is just faked by the driver.

And this does mean that L2 bridging is meaningless.  But there is
nothing preventing you from playing routing tricks.  Instead of
bridging, you could for example just move the /64 route from the wwan0
interface to some other interface.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]