Re: Network Manager patched on Ubuntu Karmic 9.10

On Wed, 2009-11-18 at 00:00 +0300, Louigi Verona wrote:
> Hey, Dan!
> Thanks for the advice. I am certainly keen on helping the community to
> solve the problem, but the bug had been reported to launchpad with
> like a dozen duplicates. The daily builds were suggested as partial
> fix but since then I could get no information from anywhere and bug
> reports on launchpad do not seem to be updated anymore. My friend was
> asking me whether he should install Karmic and I couldn't say "yes",
> since if his first GNU/Linux experience would be like that, I think
> this would not be a good thing. So eventually I decided to contact
> this mailing list directly, so that I can get some firsthand
> information.
> My dream would be to get a new version of NM. Uninstall this one,
> install this one and have it work normally like it did in 9.04 %) All
> apps get bugs like this one sometimes - I am not complaining. I just
> want to know if something is being done and if yes - when is a total
> fix planned? To me it is a serious blocker.

You can't realize that dream until we get some help in debugging the
issue so that we can fix the problem.  We also can't do anything until
users help us debug the problem by answering the questions that I've


> On Tue, Nov 17, 2009 at 11:49 PM, Dan Williams <dcbw redhat com>
> wrote:
>         On Tue, 2009-11-17 at 09:36 +0000, Cian Masterson wrote:
>         > 2009/11/17 Louigi Verona <louigi verona gmail com>:
>         > > 2. When I boot the system, NM would try to automatically
>         connect to some
>         > > Wired connection lfupdown (eth1). It seems to be there by
>         default. Since I
>         > > have no wired connection, it of course, always fails. I
>         cannot edit it, the
>         > > Edit button is grayed out when I select this connection. I
>         tried making my
>         > > DSL connection automatically connect, but then it begins
>         to ask for password
>         > > and says again "Insufficient privileges" and I have to
>         start over again. Is
>         > > there any way to remove this default non-existing
>         connection?
>         >
>         > This happened to me too, although in my case it was
>         "ifupdown (eth3)".
>         >  This left my laptop with no network access because my wired
>         > connection (which was eth5 in Jaunty) wasn't being
>         recognised.  I
>         > tried editing /etc/network/interfaces by hand but that
>         didn't work
>         > either.  Long story short I deleted /etc/network/interfaces,
>         rebooted
>         > the machine and eth5 magically reappeared and everything
>         worked fine
>         > after that.
>         >
>         > Better minds than mine will know what actually happened but
>         I am
>         > assuming that a missing /etc/network/interfaces forced
>         Ubuntu/Network
>         > Manager to re-scan the hardware or something.  As per usual
>         if you try
>         > this route yourself I recommend
>         moving /etc/network/interfaces to
>         > /etc/network/interfaces.broken or something instead of
>         deleting it.
>         > YMMV but this worked for me.
>         If people are running into problems like this on Ubuntu, the
>         best thing
>         to do to help debug the issue is to either file a bug report
>         in
>         Launchpad, or grab your /var/log/NetworkManager.log file, or
>         if that
>         doesn't exist /var/log/daemon.log and send it to this list so
>         that we
>         can try to figure out what's going on.
>         Especially int he case of PPPoE/DSL, to debug further you can:
>         1) stop NetworkManager
>         2) as root, run NetworkManager like this:
>         NM_PPP_DEBUG=1 /usr/sbin/NetworkManager --no-daemon
>         3) try to reproduce the issue
>         4) send the NetworkManager debug output to this list
>         Dan

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]