Re: GTK+ and libnotify requirements for 0.7 gnome applet

Darren Albers wrote:
On Jan 9, 2008 10:35 AM, Dan Williams <dcbw redhat com> wrote:
Two things...  First, would anyone mind terribly if the GTK+ requirement
were bumped to GTK+ >= 2.10 ?  This allows us to use GtkStatusIcon and
to get rid of the eggtrayicon.c code and the alternate packing model it
has to use.  What distros are people running (if you're using NM 0.7),
and what version of GTK does that distro use?

Second, I'd like to use the libnotify notification code exclusively and
remove the notification dialogs that get used when libnotify is not
present.  There are some user-interface improvements that I've been
thinking of that would use notification bubbles extensively.

On Ubuntu every version since Edgy (October 2006) uses GTK 2.10 or
later.   Dapper which is a LTS release is supported until 2010 (I
think) uses 2.8 but as a LTS release I assume that Canonical/Ubuntu
will stick with 0.6.5 and wouldn't backport 0.7.0.    If anyone wanted
NM 0.7 it makes sense that they are most likely running a more recent
distro anyway.

Debian uses 2.8 in it's stable release:
But Lenny and Sid are both at 2.12.   I know the Debian Maintainer
follows the list so I am sure he will say if there is an issue there.

I don't plan to provide a backport of NM 0.7 for current Debian stable.
And the versions for lenny and sid, as Darren said, are recent enough.

So from my side I'd say, go for it.

Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

Attachment: signature.asc
Description: OpenPGP digital signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]