Re: GTK+ and libnotify requirements for 0.7 gnome applet


Considering GTK+2.10 is available for year and the half now I don't think too many people who want to use _new_ software (NM7) will cry about it.
On my distribution (gentoo) the oldest available gtk+-2XX (as of today in official repository) is 2.10.14

* x11-libs/gtk+
    gentoo:                  1.2.10-r12 {:1} 2.10.14 2.12.1-r2 {:2}
    xeffects:                2.10.13 2.10.14 2.12.0 {:2}
    installed:               2.12.1-r2* {:2}
    Description:             Gimp ToolKit +
    Relevant USE flags:      (X) (cups) (-debug) (-doc) (jpeg) (tiff) (-vim-syntax) (xinerama)
    License:                 LGPL-2
    Installed time:          Mon Dec 17 09:46:31 2007
    Source repository:       gentoo
    Installed using:         paludis-0.26.0_alpha4

On Wed, 2008-01-09 at 10:35 -0500, Dan Williams wrote:
Two things...  First, would anyone mind terribly if the GTK+ requirement
were bumped to GTK+ >= 2.10 ?  This allows us to use GtkStatusIcon and
to get rid of the eggtrayicon.c code and the alternate packing model it
has to use.  What distros are people running (if you're using NM 0.7),
and what version of GTK does that distro use?

Second, I'd like to use the libnotify notification code exclusively and
remove the notification dialogs that get used when libnotify is not
present.  There are some user-interface improvements that I've been
thinking of that would use notification bubbles extensively.



NetworkManager-list mailing list
NetworkManager-list gnome org

Attachment: signature.asc
Description: This is a digitally signed message part

Attachment: smime.p7s
Description: S/MIME cryptographic signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]