Re: [gtk-osx-users] PyGTK on Lion

On Oct 23, 2011, at 12:09 AM, Shrihari Sankaran wrote:

You must not have deleted the installation directory. You can either try harder to clean up or just set build_policy = all and pass --clean on the command line to force everything to rebuild. You'll get a couple of failures for modules that don't have clean targets, just select "2 -- ignore error and continue" for each.

I did exactly that now. I added 'build_policy = "all"' to my .jhbuildrc-custom and passed --clean and rebuilt bootstrap, meta-gtk-osx-bootstrap, meta-gtk-osx-core, meta-gtk-osx-python. The first 3 went fine. But, during the build of meta-gtk-osx-python, the modules pycairo (13), pyobject(14), pygtk(15), gtk-mac-integration-python(16) failed the phases configure, clean, build and says "nothing to be done for install".

Now, when I run my app, I still get "no module named gtk". Kinda stuck here.

Duh. If a module can't configure, it won't build, and if it won't build it won't install. If you don't get pygtk installed, guess what? "No module named gtk". Duh again.

So, what did they fail configure for?

John Ralls

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]