Re: GNOME Bugzilla Upgrade: Test Upgrade On Friday?

On Tue, 2009-07-28 at 02:36 -0700, Max Kanat-Alexander wrote:
> > I want everything via RPMs unless there is a good reason not to.
> 	Okay. Here's the list of RPMs that the GNOME Bugzilla 3.4 will need on 
> RHEL5 (they should all be available in rpmforge unless otherwise noted):

OK, this is something we need to discuss - right now RPMForge is not
enabled on the machines, and I don't think we'd want to blanket enable

I don't have any particular bias against it, and in general I respect
dag's packaging work, but I'm not very familiar with it, it has a lot of
packages, and I think it packages newer/conflicting versions of stuff
already in RHEL and EPEL.

If we set up a special bugzilla web-fronted VM, then we could
conceivably enable it just for that machine if that was significantly
easier than any other approach, though having different package sources
on different machines isn't that great.

Our package policy is now, in order of preference:
 RHEL Packages
 EPEL Packages
 Local rebuilds of current Fedora packages
 Locally builds of custom packages or packages from other sources

Are version requirements for the dependencies available somewhere? I've
gone through what you've listed and checked the what's available for
RHEL5/EPEL, and where the package isn't in EPEL listed the Fedora 11
version in square brackets.

> 	perl-Digest-SHA
X [1:5.47-73.fc11]
> 	perl-DateTime
1:0.41-1.el5 (epel)
> 	perl-Template-Toolkit (At least 2.22)
2.18-1.el5 (epel) [2.20-1.fc11]
> 	perl-Email-Send
2.185-3.el5 (epel)
> 	perl-Email-MIME
1.859-1.el5 (epel)
> 	perl-Email-MIME-Modifier
1.441-1.el5 (epel)
> 	perl-Email-MIME-Encodings
1.313-1.el5 (epel)
> 	perl-URI
1.35-3 (RHEL)
> 	perl-DBD-mysql
3.0007-2.el5 (RHEL)

> 	perl-GD
2.35-2.el5 (epel)
> 	perl-Chart
X [2.4.1-7.fc11]
> 	perl-Template-GD
X [2.66-5.fc11]
> 	perl-XML-Twig
3.26-1.fc6 (rhel)
> 	perl-libwww-perl
5.805-1.1.1 (rhel)
> 	perl-PatchReader
X [0.9.5-6.fc11]
> 	ImageMagick-perl (rhel)
> 	perl-LDAP
1:0.33-3.fc6 (rhel)
> 	perl-HTML-Parser
3.55-1.fc6 (rhel)
> 	perl-HTML-Scrubber
0.08-4.el5.2 (epel)
> 	perl-Email-MIME-Attachment-Stripper
1.313-3.el5 (epel)
> 	perl-Email-Reply
1.201-3.el5 (epel)
> 	perl-Authen-SASL
2.10-1.el5.1 (epel)
> 	perl-SOAP-Lite
0.710.07-2.el5 (epel)
> 	perl-Data-ObjectDriver (this thinks it requires DBD::Oracle, but it 
> doesn't--you should be able to just force install the RPM without 
> DBD::Oracle installed)
X [0.06-3.fc11]
> 	perl-TheSchwartz
X [1.07-2.fc11]
> 	perl-Daemon-Generic
X [0.61-1.fc11]
> 	mod_perl
2.0.4-6.el5 (RHEL)

Parse::StackTrace deps

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]