Re: [Gimp-developer] I'm going slightly mad.

Am 11.01.2017 um 18:59 schrieb Simon Budig:
Thorsten Stettin (thorsten stettin gmail com) wrote:
Why do you need libpng >= 1.6.25, and lcms2 >= 2.7 in order to build Gimp
2.9.5 - commit 36ebe03770fd8b87102e95cd6c45b194a45a8ba3?
Libpng is due to security issues:

commit a5073ad9289f7e05ef38d2ce99dc71e91983b434
Author: Michael Natterer <mitch gimp org>
Date:   Mon Oct 31 09:36:15 2016 +0100 require libpng 1.6.25
Addresses bug #765850, and probably avoids a gazillion of
     vulnerabilities in the versions since the ancient 1.2.37
     we required before.

For libcms2 this is due to some rounding errors that affected some
blending modes in gimp:

commit 0ce364ee4dd2200e6607a4575af0cc657600afc9
Author: Michael Natterer <mitch gimp org>
Date:   Thu Sep 15 12:52:20 2016 +0200, app: require liblcms2 >= 2.7
and add an lcms2 runtime version check to app/sanity.c Fixes:
     Bug 736701 - LCMS2 rounding errors cause problems with certain
     GIMP blend modes

I hope this helps,

My problem is to clean backporting it for Ubuntu LTS versions since Trusty.
Are libpng 1.6.25, and liblcms2 2.7 backward compatible?


Lao-Tse sagt: Nichtstun ist besser, als mit viel Mühe nichts zu schaffen.
Und er sagt auch: Ich habe drei Schätze, die ich hüte und hege.
Der eine ist die Liebe, der zweite ist die Genügsamkeit, der dritte ist die Demut.
Nur der Liebende ist mutig, nur der Genügsame ist großzügig, nur der Demütige ist fähig zu herrschen.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]