Re: [Gimp-developer] pygtk automake problem

On 08/06/2013 11:40 PM, Owen wrote:
On Tue, 06 Aug 2013 20:07:30 -0700
Burnie West <west ieee org> wrote:

On 08/06/2013 05:13 PM, Burnie West wrote:
On 08/04/2013 03:31 PM, Burnie West wrote:
On 08/04/2013 02:49 PM, Owen wrote:
This might sound stupid, but do you have pygtk, ie, what is in

${prefix}/lib/python2.7/site-packages (on my system it's called

2.10.4 is pretty old so if its there, the version number probably
isn't the problem.
I have /usr/lib64/pygtk/2.0, which is the April 01, 2011

But it is not in /usr/lib/python2.7/site-packages.
There's LOTS of stuff there, the only pyg is pygment.

I made a softlink in sitepackages back to pygtk; same result.
Then I recursively copied /usr/lib64/pygtk to
/usr/lib/python2.7/site-packages; same result.
config.log explains pygtk-2.0.pc is missing --
"Perhaps you should add the directory containing `pygtk-2.0.pc'"

The statement is true.
However, no directory in my system contains that specific
configuration file. I have so far not figured out precisely how to
create a configuration file. Perhaps someone could show me an
example? TIA
Please forgive this string of messages, which I think may be related
to the 'git problem' thread

Absent a response, I hand-built (with considerable reluctance) a
pygtk-2.0.pc and put it in my configuration path:
My pygtk-2.0.pc is


      Name: pygtk2
      Description: Extension module for Python for GTK+-2
      Version: 2.24.0

This was progress, b/c I now proceed to this error:
      configure: error:
      *** Could not find pygtk-codegen-2.0 script.
Searching on-line, I find this information from an unrelated source
"If "pygtk-codegen-2.0" is deprecated, then upstream scripts that
call it should be updated to call "pygobject-codegen-2.0".

It is undoubtedly clear to the awesome GIMP developers - as it is
clear to me - that I'm over my head here.

I don't have past message in this thread so I don't know your

However, you have done the wrong thing by hand rolling a .pc file.

On this Suse-12.3 I have two packages, python-gtk and python-gtk-devel

When the ...-devel package is installed, the pc file is also installed,
together with all other dependencies to support  the "devel" file.

So have a look round for python-gtk-devel, or might be pygtk-dev in
other distros.

On 08/06/2013 10:49 PM, Michael Schumacher wrote:
Did you install the corresponding development packages for python, pygtk and any other needed module from 
your distro's repository?
I'm on Fedora 18.
Found and installed pygtk2-devel, installed it together with pygtklext-devel and pygtksourceview-devel, This resulted in configure success, although apparently my lcms installation seemed not to work.
Makes and installs fine

Thanks for your help :-)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]