Re: (L)GPLv3

Le mardi 06 juillet 2010, à 09:26 -0400, Ryan Lortie a écrit :
> On Tue, 2010-07-06 at 13:12 +0000, jhs jsschmid de wrote:
> > Well, while I guess all my modules are LGPL/GPLv2+ would that still
> > prevent me from linking against LGPLv3 things if I don't convert them to
> > GPLv3?
> No.
> At the point that your application is used with a LGPLv3 library then it
> would conceptually be 'upgraded' to GPLv3 at that time (so that the
> GPLv2 clause preventing linking with LGPLv3 disappears).  This doesn't
> mean that you have to change the licence of existing code -- you just
> keep it "v2 or higher".

Just to help everyone get a clear view for those questions: the
compatibility matrix at is really useful
for such questions :-)



Les gens heureux ne sont pas pressés.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]