Re: [xml] problems with zlib 1.2.5?

Hi again

himself, so it ought to be correct ! Also libxml2 and the new zlib
have shipped for a while and that's the first time I hear about
such a problem, so something weird is going on, but what ???

        i agree also that something is weird here... firefox crash all
the time, but claws-mail only crash sometimes, making harder to reproduce
the problem there. also, running claws-mail inside of valgrind i dont
get any crash. firefox, i didnt manage to run with valgrind.

  One of the things I'm wondering is the plugin for Firefox isn't
running 32 bits and somehow there is a zlib dependancy problem

        don't believe on that, first the firefox backtrace dont show
any plugin usage, nor i'm doing something that a plugin can be applied.
Second, claws-mail dont have plugins nor use anything 32bit

        i also contacted Mark Adler to see if he had any idea and got
this reply:

"On Nov 5, 2010, at 2:05 AM, higuita wrote:
Program received signal SIGSEGV, Segmentation fault.
gzdirect (file=0xffffffffdd7caa60) at gzread.c:614  

gzdirect() is trying to access an int pointed to by "context" in xmlIO.c being passed as "file" to 
gzdirect(), which is resulting in the segmentation fault.  So context, 0xffffffffdd7caa60, is not pointing to 
a valid memory location.  context is supposed to be pointing to a structure that was initialized by gzopen() 
or gzdopen().  So the fault would be caused by a bug in libxml or the application using it, where either 
context is simply uninitialized or set to something other than a pointer (and not NULL), gzdirect() is being 
called after gzclose() is called on context, something is doing a free() on context, or somehow the context 
pointer is getting clobbered between being opened and when gzdirect() is called.

Keeping zlib 1.2.3 and recompiling libxml2 2.7.7 the problem is also fixed.  

There should be no difference with respect to the reported error between libxml 2.7.7 with either zlib 1.2.3 
or zlib 1.2.5.  Both should fail when trying to access the structure pointed to by context if context isn't 
pointing to anything.  
When you say "recompiling" is makes me wonder if there might be a difference between the zlib headers you are 
compiling libxml2 with and the zlib library you are using.  Is the problem fixed if you use zlib 1.2.5 after 
recompiling libxml2 2.7.7 with zlib 1.2.5?"

        i tried to clean both libs of the system, download again both 
the zlib and libxml2 source packages, done a clean recompiled of zlib,
installed, then libxml2 and install... but the apps still crash.

        i even tried to compile without optimizations on both libs, but
same result. could this be a compiler (gcc 4.5.1) or a glibc bug (2.12.1)?

        if i have time during the next few days, i will try to test 
a clean slackware64 install to check if its something bad with my

        I'm also open to any other ideas and any test you may want.

thanks for the help.
Naturally the common people don't want war... but after all it is the
leaders of a country who determine the policy, and it is always a 
simple matter to drag the people along, whether it is a democracy, or
a fascist dictatorship, or a parliament, or a communist dictatorship.
Voice or no voice, the people can always be brought to the bidding of
the leaders. That is easy. All you have to do is tell them they are 
being attacked, and denounce the pacifists for lack of patriotism and
exposing the country to danger.  It works the same in every country.
           -- Hermann Goering, Nazi and war criminal, 1883-1946

Attachment: signature.asc
Description: PGP signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]