Re: [Shotwell] Unable to import photos from Samsung Galaxy S6 anymore


I finally got a new PSU and time to set it up and re-try to sync my photos.

It turned out that I didn't have gphoto2 installed (maybe because I have a dev enverionment and I messed up something?)

If now I execute gphoto2 -T I get the following error:
*** Error ***             
PTP Session Not Open

*** Error ***             
An error occurred in the io-library ('Unspecified error'): The supplied vendor or product id (0x0,0x0) is not valid.
*** Error (-1: 'Unspecified error') ***

I attach also the debug log file I get when running gphoto2 in debug mode.



On 10 October 2016 at 00:32, Abel <akronix5 gmail com> wrote:
The PSU of my computer isn't in a healthy state right now, so I'll have to delay the check.
But I will do it as soon as possible and get back to you the results.

Thanks Jens,


On 9 October 2016 at 22:03, Jens Georg <mail jensge org> wrote:
On So, 2016-10-09 at 21:14 +0200, Abel wrote:
> Hi!
> I usually backup my mobile photos and media with shotwell.
> After plugging my phone in, I have to unmount the device from the
> filesystem (else shotwell complains that it can't claim the usb the
> device) and then I'm able to see and import the photos pressing on
> the device icon located at the sidebar.

Yep, that's annoying, I know.

> Well, this was like that until yesterday. After some months without
> backing up my phone, I plugged it in, followed the steps several
> times and tried a bunch of things; but shotwell doesn't let me see
> and import my photos anymore. Instead, it displays a dialog with this
> text:
> Unable to fetch previews from the camera:
> Unspecified error (-1)
> At first, I was using shotwell 0.23.7, but then I downgraded to the
> version coming with Ubuntu
> 16.04 repos (0.22.0) to see if the problem came from a newer version
> of shotwell. Neither case worked.

I would rather suspect that this is an issue with a newer gphoto2. Can
you follow the steps from
1905 as well?

shotwell-list mailing list
shotwell-list gnome org

Attachment: my-logfile.txt
Description: Text document

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]