Re: Build librep error: autoheader: warning: missing template: XXXXXXXXX

Michal Jaegermann wrote:
On Wed, Jan 28, 2009 at 10:05:49PM +1100, Allan Duncan wrote:
Ian Zimmerman wrote:
Allan> So I got the latest from F11 development, but I am now getting
Allan> complaints that I have 2.2.6 not 2.2.2 - a bit too restrictive on
Allan> versions?

Does libtolize --force --copy after autogen help at all?

This is why I hate the autotools ... and particularly libtool.
I'll have a look.  The whole process of making an RPM is cludgy,
I first have to run to create a heap of things, including
librep.spec, then repackage it all up for feeding into rpmbuild.

Well, no.  If you will do that then you will end up with a
definitely broken source package which is good only for one
particular version of autotools.  You run as a part of
%build section instead.

The problem is that depending on a version of libtoolize
you need for it an --install option or it such option is not
accepted at all.  To get around that I do in spec files something
like this:

%if %( t="$(libtoolize --version | sed -n '1s/.* //p')"; \
        t="${t%%%%.*}"; [ "$t" -a $t -le 1 ]; echo $?)
%define ltv 2

and later in %prep section

%if %{defined ltv}
%patch1 -p1 -b .m4conf

where such patch modifies accordingly a suitable script.

I did not look at the latest changes yet but source packages with
such spec files worked for me the same in Fedora-rawhide and Fedora
9 and CentoOS5.

I follow what you are saying in general, but I have a problem with what
I feed into "rpmbuild -ba librep.spec" ?  All I have in the svn is, and to turn that into librep.spec is to run the  I've tried so many variations I ended up confused, so I
re-ran a set from scratch:
To get a librep.spec file, to the svn-2974 I added, from librep.0.17.2,
config.guess (this wasn't needed to get librep.spec, but there were error
            messages about not finding it)

I no longer get the message about libtool version 2.2.2 vs 2.2.6, but the
rpmbuild dies with this _interesting_ set of errors:

make[1]: Entering directory `/home/alland/rpmbuild/BUILD/librep-0.17.3/src'
gcc -c -DHAVE_CONFIG_H -I. -I../src -I.. -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -o repdoc.o repdoc.c
/bin/sh ../libtool --mode=link --tag=CC gcc  -o repdoc repdoc.o -lgdbm
../libtool: line 827: X--mode=link: command not found
../libtool: line 827: X--tag=CC: command not found
../libtool: line 860: libtool: ignoring unknown tag : command not found
../libtool: line 994: *** Warning: inferring the mode of operation is deprecated.: command not found
../libtool: line 995: *** Future versions of Libtool will require --mode=MODE be specified.: command not found
../libtool: line 2408: Xrepdoc: command not found

Fatal server error:
Server is already active for display 0
	If this server is no longer running, remove /tmp/.X0-lock
	and start again.

../libtool: line 2420: Xrepdoc: command not found
../libtool: line 2428: mkdir /.libs: No such file or directory
mkdir: cannot create directory `/.libs': Permission denied
make[1]: *** [repdoc] Error 1
make[1]: Leaving directory `/home/alland/rpmbuild/BUILD/librep-0.17.3/src'
make: *** [src/repdoc] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.hNRnU3 (%build)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]