Re: Renaming 'grow, pack, shrink & yank'?

I was looking at the documentation for yank:

"Yanks window left until it inserts with one window less than before."

I don't think this is very explicit. I think it should say "overlaps"

An antonym of overlap is separate. I kind of like that term for what I
understand yank does.

Pack is more about tiling, in my opinion, than packing. 


 Timo Korvola twisted the bytes to say:

 Timo> On Tuesday 29 December 2009 07:47:20 Teika Kazura wrote:
 >> Is 'bump' better than 'pack'?

 Timo> In my opinion, pack is probably the best of the four names.  In fact the 
 Timo> entire category might be called "Window packing".  But could renaming 
 Timo> pack enable us to find a better name for yank, which is the sore spot?  
 Timo> Bump would not seem to help there.  Perhaps rename pack to push and yank 
 Timo> to pull?

 >> 'Yank' is difficult.

 Timo> I know.  It is the best name I could come up with, despite some 
 Timo> confusion caused by its use in Emacs and Vi with meanings that are 
 Timo> rather distant from the colloquial one.

 >> Does any know an alternate? (I came up with 'rip', 'flee',
 >> 'away', and so on, but none is better.)

 Timo> Unpack perhaps?  It would be understandable as kind of opposite to the 
 Timo> pack commands, although somewhat misleading because the windows remain 
 Timo> packed closely together, only with less overlap.

 >> Change on these items can be implemented using wm.util.compat, which
 >> stores obsolete definitions.

 Timo> Changes would still be a nuisance to users, just a delayed one.  People 
 Timo> have key bindings for these commands.

 Timo> -- 
 Timo> 	Timo Korvola		<URL:>

Daniel M. German         
dmg (at) uvic (dot) ca
replace (at) with @ and (dot) with .

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]