Re: Renaming 'grow, pack, shrink & yank'?

On Tuesday 29 December 2009 07:47:20 Teika Kazura wrote:
> Is 'bump' better than 'pack'?

In my opinion, pack is probably the best of the four names.  In fact the 
entire category might be called "Window packing".  But could renaming 
pack enable us to find a better name for yank, which is the sore spot?  
Bump would not seem to help there.  Perhaps rename pack to push and yank 
to pull?

> 'Yank' is difficult.

I know.  It is the best name I could come up with, despite some 
confusion caused by its use in Emacs and Vi with meanings that are 
rather distant from the colloquial one.

> Does any know an alternate? (I came up with 'rip', 'flee',
> 'away', and so on, but none is better.)

Unpack perhaps?  It would be understandable as kind of opposite to the 
pack commands, although somewhat misleading because the windows remain 
packed closely together, only with less overlap.

> Change on these items can be implemented using wm.util.compat, which
> stores obsolete definitions.

Changes would still be a nuisance to users, just a delayed one.  People 
have key bindings for these commands.

	Timo Korvola		<URL:>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]