Re: [Rhythmbox-devel] Re: Genre not getting updated

On 4/25/06, Alex Lancaster <alexl users sourceforge net> wrote:
> >>>>> "DB" == David Berg  writes:
> DB> I just had a very strange interaction with rhymbox.  I eventually
> DB> got it to move, but maybe this description will help isolate a
> DB> bug.
> DB> I changed the Genre tag for an album using Easytag.  Rhythmbox
> DB> moved all but one of the songs to the new genre automatically but
> DB> one is stuck with the original tag.
> DB> Easytag shows that the new genre is applied.  Viewing the file in
> DB> a text editor, I see GENRE=Acoustic (the new tag).  I've tried
> DB> restarting rhythmbox, importing the directory and song again.  The
> DB> song is still listed under Other (the original tag).
> DB> I removed the song from the Rhymbox database (right click->remove)
> DB> and tried to reimport it but it isn't added.  I just stopped the
> DB> program and restarted it from a command line to see if there were
> DB> any errors being printed and when the program reloaded, the song
> DB> was found and properly placed.
> DB> Let me know if you want the file or if there's anything else I can
> DB> elaborate on.
> Did the track happen to have an ampersand in the file name or in the
> track title?  If so, it's probably a file canonicalisation problem
> where there was an entry that wasn't properly refreshed, see:

I don't remember that being the case, nor do I remember which file it
was at this point.  It happened a number of times as I was sorting
through a library.  If it happens again I'll look to see what the
filename is.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]