Re: Updating minimum version of an existent external dep

El mié, 15-08-2007 a las 19:38 -0600, Elijah Newren escribió:
> On 8/15/07, Carlos Garcia Campos <carlosgc gnome org> wrote:
> > Hi all,
> >
> > I'm wondering if there is a restriction on when we can update a minimum
> > requirement of an external dependency in the release cycle. The question
> > is that poppler 0.6 rc2 has just been released and there are plans to
> > release poppler 0.6 on 15th of September. That's very late in the GNOME
> > schedule. Poppler API (actually glib bindings, which is the part evince
> > depends on) is going to change (breakage) before poppler 0.6, so I would
> > like to release evince 0.10 (to be released in GNOME 2.20) depending on
> > poppler 0.6 since it will be more API stable. I've already proposed to
> > release 0.6 earlier, but I'm not sure if the GNOME schedule is a good
> > reason for the other poppler guys.
> >
> > Anyway, If it's too late to update the minimum required version, we can
> > just release evince 0.10 depending on poppler rc2 and update the
> > requirements later during 2.21/2.22.
> There's no restriction in the rules we've written; just whether you
> can get consensus for the change.  :-)
> Sept 15 is indeed really late in the schedule for us, and I worry
> about whether their release would slip; but if you're fine releasing
> an evince that depends on a release candidate, then I guess we could
> always use it as a backup.
> So, I think I'm okay with this but I'd like feedback from others in
> the team for their opinions.  Also, either way, please keep us
> informed of any changes in the poppler schedule.

1st September has been proposed, I think it's much more appropriate for
us, just before GNOME 2.19.92

> Elijah

Carlos Garcia Campos
   elkalmail yahoo es
   carlosgc gnome org
PGP key:

Attachment: signature.asc
Description: Esta parte del mensaje =?ISO-8859-1?Q?est=E1?= firmada digitalmente

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]