Re: Problems with Networkmanager 0.7

Nope, hav'nt done anything with the device, the 169G treats both 3UK and Orange as "Available" networks.

Where i live/work south London/reading the 3 signal strength varies widely, so it often ends up locked onto the orange network.

On 14 Oct 2008, at 20:16, Stuart Ward wrote:


I have tried NM 0.7 with both the e169, and the e220 and they worked
just fine without any configuration etc. I presume that you have
somehow cleared out the config setting for the home network and that
is why you are having to reset it. I am presuming you are using a 3 UK

-- Stuart Ward M +44 7782325143

On Mon, Oct 13, 2008 at 9:01 PM, Tim Hawkins <tim hawkins mac com> wrote:
I hav'nt tried setting the network entry, the last version i had that was
not active.

In the uk with three, the 2G and 3G services are provided by two different
providers with
separate network numbers, both networks are "available", and the module
will often lock onto
the one with the highest signal strength. Here Three does the 3G whilst
does the 2G fallback. This means that without a "kick" it often wont lock
the right network.

On 13 Oct 2008, at 19:58, Dan Williams wrote:

On Mon, 2008-10-13 at 19:51 +0100, Tim Hawkins wrote:

I have the 169G which is basically a very similar device with the same
command language produced by the same manufacturer, and I have the
same problem. The 169G is detected as a Huawei 620

I use a small script file with

echo "AT+COPS=1,2,23420" > /dev/ttyUSB2

to achieve the same result. "23420" is the network number for 3 UK.

Does the module not automatically register with the home network?

Also, does setting "23420" in the connection editor's "Network:" entry
not work for you?


After using this command the modem switches from green flashing (GSM)
to Blue Flashing (3G) , and network manager can dial and connect.

To find the network number i use minicom with "AT+COPS=?" which
returns a list of available networks.

On 13 Oct 2008, at 19:36, Dan Williams wrote:

On Mon, 2008-10-13 at 10:42 +0800, Ronald Wiplinger (Lists) wrote:

Ronald Wiplinger (Lists) wrote:

The latest version worked for me, but stopped working.

I think I found a way that it works.
I have to use first wvdial hspda, which gets my E220 to flash
(slow) in
blue and then the Network manager can connect.

I tested this way several times on two different notebooks and it
each time.

Is there a special AT command that the modem needs to be put into data mode or something? Could you paste the wvdial config (ie, modem init
strings) into a reply?

Tambet: you've got an E220, right?




I got a message entry (I agree with it, it is true ;-)  ):

event field not found

There is not even a /home/adamm on my system ;-)

Another questions:

1. How can I switch back to a previous (working) version?
On one of my EeePCs the user accidently upgraded, now he cannot
anymore. Would be great if there would be a way to switch back.

2. I would need following configuration, how can I set this up:
Connect via EeePC to the Internet, and because there is no
Wireless lan
provide wireless connection to other notebooks in that area.



NetworkManager-list mailing list
NetworkManager-list gnome org

NetworkManager-list mailing list
NetworkManager-list gnome org

NetworkManager-list mailing list
NetworkManager-list gnome org

NetworkManager-list mailing list
NetworkManager-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]