Re: Problems with installation of Gtk2 on SUSE 9.1

Thanks muppet,
I appreciate your reply.
The shebang line was just #! -w ...

On Tue, 2005-09-27 at 17:00, muppet wrote:
On Sep 27, 2005, at 6:21 PM, Pih Lung Pang wrote:

I am trying first to install Gtk+-2.8.3, because that is
Gtk2(correct?) and then Gtk2-Perl.
But I ran into problems, when trying to install the dependencies for
Gtk+-2.8.3: Glib-2.8.2, ATK-1.10.1, Pango-1.10.0, Cairo-1.0.0,
fontconfig-2.3.2 and freetype-2.1.10.

Save yourself a lot of grief; don't try to install gtk+ from source.   
Use binary packages, instead.
Where can I find the latest binary packages/rpm's(for SUSE)??
I could only find the source code from!

I then used YaST2 to restore and "downdate" GTK and the dependencies.
Whether I use "install and remove software" or "Online update", these
are the newest I could get running SUSE 9.1.
Gtk+2-2.2.4, Glib-2.2.3-117(c), ATK-1.4.1-124, Pango-1.2.5-170,
freetype-2.1.7-53, glade-2.0.1-47
But they are working. I used Glade to design a hello world window, and I
could run it. Great fun!

I then wanted to install the Gtk2-Perl package from
and I found binary files for fedora(fc4.rpm) and redhat(rh8/9.rpm), but
not for suse. Their was a source src.rpm, is that for all distributions?

Well, I compiled from source Glib-1.100(perl),
perl-ExtUtils-Depends-0.205,perl-ExtUtils-PkgConfig-1.07 and
Gtk2-1.100 without serious problems.(Gtk2: make test -> -6/3105 subtest
failed, 100.19% okay ;) I'm ready!!

I tried a Hello World Perl-GTK2 script and it worked just perfect.
What benefits are there in upgrading to the latest versions of

I continue with Glade-Perl and win32..

Best regards,


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]