Re: [gtk-osx-users] Trouble building meta-gtk-osx-bootstrap

On Oct 21, 2012, at 3:41 PM, John Ralls <jralls ceridwen us> wrote:

First, when it tries to install zlib, I get the error: `cp: /usr/local/lib/libz.a: Permission denied.` I dropped into the shell and ran `sudo make install`. That seemed to work. (I also tried just temporarily making myself the owner to /usr/local/lib/, with less luck.)

Something's wrong there. It didn't get prefix set correctly (/usr/local is the default). It should be installing where everything else is going (~/gtk/inst unless you changed it in .jhbuildrc-custom). I just did a check-build of zlib and it installed in the right place, so I'm at a bit of a loss about how it configured wrong.

I haven't changed anything in .jhbuildrc-custom. But I went back and re-ran some things, and I realized I left out a step I had taken. If I delete both ~/gtk/source/pkgs/zlib[…] and ~/gtk/source/zlib[…], and then run `jhbuild build zlib`, my first error actually looks like this: 

*** Building zlib *** [1/1]
Please use ./configure first.  Thank you.
*** Installing zlib *** [1/1]
make install
make: *** No rule to make target `install'.  Stop.
*** Error during phase install of zlib: ########## \
    Error running make install *** [1/1]

I get the same thing if I delete those files and then try to build Gramps. The first time, after I had gotten that error, I dropped into shell and ran `configure`, then `make`, then `make install`—and then I got the 'Permission denied' error. Is it installing the wrong place because I ran the configure script without the right prefix flags? If so, how do I add the right ones?

Don't keep going when you hit an error!

Ha, sorry! I thought I had sorted out which were dependency errors and which weren't, and I was anxious about littering everyone's inboxes with error after error. But I take this point. I will henceforth stop when I hit an error.

-- Brian

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]