Re: [gtk-osx-users] Trouble building meta-gtk-osx-bootstrap

On Oct 21, 2012, at 11:16 AM, Brian Hamilton-Vise <bdhamilton gmail com> wrote:

> On Oct 21, 2012, at 11:27 AM, John Ralls <jralls ceridwen us> wrote:
>> When you hit an error, you have to stop and resolve that error. Going on to the next module just means that you lack a dependency down the road and something else will fail. I guess you learned that.
> Yes, that was clear. I didn't realize how many of the errors I was getting were dependency errors until I wrote it out. 
>> I haven't seen the .gir issue before. The simplest way around that is to add
>>  append_autogenargs("pango", "--disable-introspection") 
>> to your .jhbuildrc-custom. That will probably cause Gtk to fail because of missing the Pango .girs, so you should add
>>   append_autogenargs("gtk+", "--disable-introspection")
>> as well.
> Worked like a charm. Once again, thanks. I ended up having to do the same thing for osmgpsmap, as I was trying to install gramps. 
> I'm on the home stretch now, but I'm running into a few more hangups I can't find my way through as I try to build gramps.
> First, when it tries to install zlib, I get the error: `cp: /usr/local/lib/libz.a: Permission denied.` I dropped into the shell and ran `sudo make install`. That seemed to work. (I also tried just temporarily making myself the owner to /usr/local/lib/, with less luck.)

Something's wrong there. It didn't get prefix set correctly (/usr/local is the default). It should be installing where everything else is going (~/gtk/inst unless you changed it in .jhbuildrc-custom). I just did a check-build of zlib and it installed in the right place, so I'm at a bit of a loss about how it configured wrong.

> But later, when the system tries to configure WebKit, it fails because it can't find zlib. It suggests that I `consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix.

Because it got installed in the wrong place.

> Alternatively, you may set the environment variables ZLIB_CFLAGS and ZLIB_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details.` But I couldn't quite parse that.

Yeah, that would be a work-around, but better to figure out why zlib got misconfigured. 

> Second, while making graphviz, I get the following error:

Don't keep going when you hit an error!
> Making all in gvc
>   […]
>   CC     gvc.lo
> make[3]: *** No rule to make target `-lltdl', needed by `'.  Stop.
That's a screwed up makefile: -lltdl shouldn't be a target.
> And finally, while configuring pyexiv2, I get: `/bin/sh: ./configure: No such file or directory.` And indeed, there is no configure file there. The install instructions for pyexiv2 have you run `scons` and `scons install` instead, so I tried dropping into the shell and running those, but was quickly met with a host of errors.

Did Scons get built? What about boost-python?

Everything you've mentioned in this list is actually optional, so if everything else is OK, you should be able to 
jhbuild buildone gramps 
and go to work. Some of the reports won't work since they don't have graphviz, but Webview (which is what requires WebKit -- which I don't even put in the app bundle because it's so big) and PyExiv2 (for editing the exit data on images) aren't necessary for almost all users.

JOhn Ralls

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]