Re: ATK dependency


Sorry to bother you again. I am looking at gtk+-3.8.2, the word "at-spi2" was not mentioned in the whole source tree:
find . -type f | xargs grep "at-spi2"
Nothing returned.  Whereas, 'atk-bridge' appeared in several places:

./configure:   ATK_PACKAGES="atk atk-bridge-2.0"
./   ATK_PACKAGES="atk atk-bridge-2.0"
./gtk/a11y/gtkaccessibility.c:#include <atk-bridge.h>
./gtk/gtkmodules.c:      g_str_equal (name, "atk-bridge"))
./README:  on the bus is now used by default; atk-bridge has been converted
./README:  pass --without-atk-bridge when configuring GTK+.
./NEWS:  on the bus is used by default (atk-bridge has been converted into
./NEWS:  pass --without-atk-bridge when configuring GTK+.

In the file, String: "atk atk-bridge-2.0" was assigned to Macro ATK_PACKAGES

That was in turn assigned to GTK_PRIVATE_PACKAGES
The PKG_CECK_MODULES finally work on it and cause the problem.
The string "atk-bridge-2.0" was also hardcoded into a C-functions.
In version, GTK+ 3.5.6, the --without-akt-birdge configuraton option was mentioned, but not working at this current version.
Even you use ./configure --without-atk-bridge, the configuration script is still not working.

Will it be save to change the string value of atk-bridge to at-spi2 in the autoconf system and the C-code?

I could not find a distribution web site for atk-bridge.  This is rare.  I did managed to get an rpm package, and it was asking for very old packages:
rpm -i libatk-bridge-devel-2.8.1-1.mga4.i586.rpm
warning: libatk-bridge-devel-2.8.1-1.mga4.i586.rpm: Header V3 RSA/SHA1 Signature, key ID 80420f66: NOKEY
error: Failed dependencies:
    libatk-bridge2.0_0 = 2.8.1-1.mga4 is needed by libatk-bridge-devel-2.8.1-1.mga4.i586
    devel(libatk-1.0) is needed by libatk-bridge-devel-2.8.1-1.mga4.i586
    devel(libatspi) is needed by libatk-bridge-devel-2.8.1-1.mga4.i586
    devel(libdbus-1) is needed by libatk-bridge-devel-2.8.1-1.mga4.i586
    devel(libglib-2.0) is needed by libatk-bridge-devel-2.8.1-1.mga4.i586
    devel(libgobject-2.0) is needed by libatk-bridge-devel-2.8.1-1.mga4.i586
I am not sure this rpm package is the right package or not. 

I have installed all the other required packages needed by GTK+-3.8.
Do you happen to have a tarball for atk-bridge?

Thanks for your information again.
Regarding to autoconf, I have been using it for a long time.  I would say, I only know about 5% of the "autohell".
In the past, I always try to avoid autoconf as much as possible.  Now, I am planning to order a book and started to get deeper into this.  I may have to use it for my own projects. 


From: Chris Vine <chris cvine freeserve co uk>
To: Kemin Zhou <kmzhou4 yahoo com>
Cc: "gtk-list gnome org" <gtk-list gnome org>
Sent: Saturday, July 13, 2013 12:09 PM
Subject: Re: ATK dependency

On Sat, 13 Jul 2013 07:21:30 -0700 (PDT)
Kemin Zhou <kmzhou4 yahoo com> wrote:
> Chris,
> Your information is very important.  I was suspecting that.  I
> installed at-spi2-atk last night, and the configure is still not
> recognizing it.  It is likely, other packages may also needed.  It
> seems that the at-spi2-atk installed the pkgconfig.  I may also need
> to do ldconfig after the installation.  
> Did anyone write any FAQ for this?  I was going through the FAQ list,
> and did not find anything.  In the end, these packages must satisfy
> the Linux linking system.  My RedHat 6.4 distribution is missing a
> lots of staff, and the yum program is disabled by the company.  The
> IT people make sure that this computer cannot be updated by any
> simple means.  I have to use the download and compile channel.  
> Anyway, I will give it another try.

You can see the dependencies by looking at  It certainly
has a dependency on atk and at-spi2-core.

If you are installing from source you are expected to know what you
are doing.  The best thing is to install the packages provided by your
distribution: most distributions provide automatic package management
for their binary packages.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]