Re: get_transform crashes with pygoocanvas0.14

On Sat, Jun 27, 2009 at 10:59 AM, Bruno Coudoin<bruno coudoin free fr> wrote:

> Next stage, that's a real mess, what is the process to distribute a
> pygoocanvas application. Why does goocanvas 0.14 requires cairo 1.4
> while pygoocanvas requires pycairo 1.8 ?

The problem is that PyCairo broke API in 1.8.0 so people using
pygoocanvas from that release on experienced segfaults.
Even worse PyCairo 1.8.0 and 1.8.2 are buggy in the very same API that
was broken before so I had to require 1.8.4 at least.

I cannot do anything about that unfortunately.

Gian Mario Tagliaretti
GNOME Foundation member
gianmt gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]