Re: Errors while trying to get jhbuild

Le lundi 07 février 2011 à 01:15 +0530, shirish शिरीष a écrit :
> In any case not willing to lower the library versions as it took me
> quite sometime to get my system working with Firefox 4.0b10 . I
> *think* most of the libraries which are in conflicts are those which
> are because of firefox 4.0b10 . Atleast xulrunner one and libnss3 I
> know of.
Yes, this most likely comes from an incompatibility introduced by the
repository you added to get Firefox 4. It has nothing to do with the
install script being buggy.

I'd say you should try building the Shell without installing the
packages that conflict, and see if that works (and if not, what is still
missing). Most of them are provided by already installed packages with
more recent versions. So just skip those :
>   libreadline5-dev: Conflicts: libreadline-dev but 6.1-3 is installed.
>   libpixman-1-dev: Depends: libpixman-1-0 (= 0.16.4-1) but 0.21.4-2 is
> installed.
>   libnss3-dev: Depends: libnss3-1d (= 3.12.8-1) but 3.12.9-1 is
>   libreadline6-dev: Conflicts: libreadline5-dev but 5.2-7 is to be
>   libcairo2-dev: Depends: libcairo2 (= 1.8.10-6) but 1.10.2-1.1 is

Maybe you'll have to find what are their equivalents for your
repositories. E.g. just try 'apt-get install libpixman'[Tab][Tab] and
see what completion suggests.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]