Re: gnome-pilot and pilot-xfer restore don't work

On Thu, 2007-05-03 at 11:22 -0400, David A. Desrosiers wrote: 
> On Thu, 2007-05-03 at 16:18 +0100, Matt Davey wrote:
> > > I tried "rmmod visor" but got the same dialog again.
> > 
> > visor will be reloaded by udev when you attempt a sync, unless it is
> > blacklisted... 
> I don't think this is true, unless udev changed behavior very recently
> to facilitate this. What happens if you have 4 Palm devices (or 7 or 30)
> all synchronizing across the various visor interfaces, and all of them
> completing at different times? 
> If visor was reloaded when the first one completed, or when one
> disconnected prematurely, etc... it would cause bad mojo ;)

But the udev auto-loading visor is the only explanation that makes
sense...  I just tried blacklisting visor and adding the
60-libpisock.rules file to /etc/udev/rules.d as described in the README,
did /etc/init.d/udev restart (even rebooted), but it doesn't work:
connecting the device always loads visor and interferes with libusb. :-(

Now I have another problem: a 700p which doesn't restore at all with
usbserial.  I haven't seen anything on the pilot-link or gnome-pilot
lists on this, and the web is not much help.  If people have ideas on
getting libusb to work I'm happy to keep trying for a couple of days,
but fortunately they also gave me a fixed 600 to fall back on.

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

Welcome to the best software in the world today cafe!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]