Re: gnome-pilot and pilot-xfer restore don't work

On Thu, 2007-05-03 at 07:55 -0400, Adam C Powell IV wrote:
> On Wed, 2007-05-02 at 18:06 +0100, Matt Davey wrote: 
> > 
> > Have you tried using a different connection type?  Try a network sync,
> > if you can configure that with your Treo.  Failing that, have you tried
> > both a libusb sync and a usbserial sync?
> I had been using usbserial.  I just switched to the "usb:" device and
> tried again, but this dialog came up:
>         Failed to connect using device `Cradle' on port `usb:'.  Check
>         your configuration, as you requested new-style libusb `usb:'
>         syncing, but have the old-style `visor' kernel module loaded.
>         You may need to select a `ttyUSB...' device.

Now isn't that a nice, informative message? :)

> I tried "rmmod visor" but got the same dialog again.

visor will be reloaded by udev when you attempt a sync, unless it is

> How do I try libusb in Debian?  Is udev automatically assigning visor to
> this?


Another data-point: I tried using the applet 'restore...' function
today, with a non-blank pda.  It didn't do much, and I noticed that the
restore requests pile up in ~/.gnome2/gnome-pilot.d/queue.  Not sure
what's going on... the corba/glib/signalling layers in gnome-pilot are
truly byzantine.  Not my favourite code.  To be honest, I haven't yet
found the gnome-pilot code that calls into pilot-link for restoring
files!  I don't have much time to spend on this at the moment, but I'll
see what I can do.


Matt Davey        "I wonder if other dogs think poodles are members of a
mcdavey mrao cam ac uk 	weird religious cult".  -- Rita Rudner

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]