2008/12/30 Daniel Espinosa <esodan gmail com>Thanks for your help.
I have a question:
I'm implementing most of the gda-easy functions, but found that:
GdaRepetitiveStatement *gda_prepare_insert_row (const gchar *table, GError ** error, ...)
GdaRepetitiveStatement *gda_prepare_update_row (const gchar *table, GError ** error, ...)
GdaRepetitiveStatement *gda_prepare_delete_row (const gchar *table, GError ** error, ...)
gboolean *gda_append_values_list (GdaRepetiveStatement *rstm, GError **error, ...)
Could be:
GdaRepetitiveStatement *gda_repetitive_statement_prepare_insert_row (const gchar *table, GError ** error, ...)
GdaRepetitiveStatement *gda_repetitive_statement_prepare_update_row (const gchar *table, GError ** error, ...)
GdaRepetitiveStatement *gda_repetitive_statement_prepare_delete_row (const gchar *table, GError ** error, ...)
gboolean *gda_repetitive_statement_append_values_list (GdaRepetiveStatement *rstm, GError **error, ...)
What do you think?
I would prefer that they remain gda_prepare_*() because they are in fact an application of the GdaRepetitiveStatement, which can be used in other contexts. However, the gda_append_values_list()'s name could benefit from having a better (=easier to understand) name.
Vivien
Attachment:
PATCH-GdaRepetitiveStatement-gda_gtype_to_string-GdaEasy.diff.tar.bz2
Description: BZip2 compressed data