Re: [gnome-db] libgda: Public and semi-public API?

On 1/16/07, Murray Cumming <murrayc murrayc com> wrote:
On Tue, 2007-01-16 at 22:13 +1000, Bas Driessen wrote:
> I agree that there needs to be much more documented, but it is a mess
> out there in the various Linux distributions, where different
> development libgda versions are used in various official
> distributions. So as soon as the API design is done, please release.
> Documentation can be added in follow up patch style releases. It has
> been several years since the last official libgda (1.2) release, so it
> needs to get out there.

I agree that things are a mess. However, I also know that API problems
are often found only when documenting the API. And you can't change API
after you've released a .0 version. Unless you do a new
parallel-installable version of the API.

The documentation which relies on gtk-doc is quite up to date with the
API, but what's missing are general guidelines or FAQ style
informations. There is however some documentation about the migration
from the previous stable versions, and some code example in the
gnome-db-demo program.

Of course any new documentation is always welcome.

About the new release, I'm currently fixing some problems with BLOB
fields in the providers which support them, and testing the whole
libraries with a custom personnal application to test the useability
of the API in a "large scale" application. I would like to do a
release 3.0 when there are no blocking points (the remaining problems
will go into minor releases).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]