Re: [gdm-list] gdm doesn't use /etc/ libraries. [SOLVED]

On Fri, Sep 26, 2008 at 10:07 AM, Patrick Scheibe
<pscheibe trm uni-leipzig de> wrote:
> Hi,
>> env LD_DEBUG=libs LD_DEBUG_OUTPUT=/tmp/ld.log <your program>
> great, that solved the problem and shows that I'm a fool.
> My prog depend on the Intel Threading Building Blocks for
> parallelization which are under ~/build/lib. To use this I have to
> compile with the Intel Compiler which installs itself
> to /opt/intel/foo/bar. The Intel Compiler shares some of the GNU
> libraries but it has own libs too. On console programs created with the
> intel-c work fine since it sets the environment automatically. I didn't
> add these libs to and so Mathematica gave a cryptic error
> message and I assumed the Intel TBB were the problem.

For future reference, you can run the command ldd to see how the
dynamic linker will resolve the needed libraries of your program.

ldd <your program>

This would probably have shown the problem earlier because ldd would
report that the intel compiler libraries weren't found (unless
LD_LIBRARY_PATH was set to include that path).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]