Re: [Evolution] Folder contents have disappeared and new error

Frankly, it was a mess. But I have now sorted it out.  I believe, what I should not have done, was to have tried to add the exchange account via the Evolution preferences menu. As I see it, the correct approach with my configuration was
1. Install evolution-ews
2. Add the exchange account via gnome system preferences -> on-line accounts

Evolution-ews seems to pick up that account entry, add it to its account list and everything works perfectly thereafter!

(I am running
Opensuse Release 12.3 (Dartmouth) 64-bit
Kernel Linux 3.7.10-1.16-desktop
GNOME 3.6.2 with Evolution 3.6.4)

Unless I have overlooked something, the whole mess with adding the account via the Evolution preferences seemed obvious but was, apparently, not the way to do it

Anyway, my problem is now solved

Many thanks for your help


On Mon, 2013-10-14 at 09:06 +0200, Milan Crha wrote:
On Fri, 2013-10-11 at 12:56 -0400, Alan Finger wrote:
> he reported error was "Cannot get folder
> '/home/myName/.local/share/evolution/mail/local/.NameOfFolder': not a
> maildir directory.".

the error can be shown with various circumstances. One way the
evolution(-data-server) code recognizes a maildir folder is that it
contains three subfolders: cur, new and tmp. If any of these is missing,
then you get a similar error.

It seems to me that your migration to maildir didn't work properly. In
case you still see old mbox files (one file for folder, contains all the
folder content), then you can open it with a custom account which would
point to the respective file, but those files are probably obsolete
anyway, you might have more recent content in the to-be-maildir folders.

I would try the above add subfolders thing, as the first step.

evolution-list mailing list
evolution-list gnome org
To change your list options or unsubscribe, visit ...

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]