Re: [Evolution] learning to compile, need help with finding dependecies in Ubuntu 10.04

Am Samstag, den 15.01.2011, 11:58 +1300 schrieb Victoria Spagnolo:
On Fri, 2011-01-14 at 23:43 +0800, Ng Oon-Ee wrote: 
On Fri, 2011-01-14 at 14:39 +0100, Thomas Mittelstaedt wrote:
Am Freitag, den 14.01.2011, 18:48 +1300 schrieb Victoria Spagnolo:
Thanks to Thomas Mittelstaedt I have made progress. I have other
errors but I want to get all the dependencies first. I've solved a
handful using Ubuntu repos, but Ubuntu maverick has earlier versions
of these 
configure: error: Package requirements (libebook-1.2 >= 2.32.2
       libecal-1.2 >= 2.32.2
       libedataserver-1.2 >= 2.32.2
       libedataserverui-1.2 >= 2.32.2
       libegroupwise-1.2 >= 2.32.2
       libebackend-1.2 >= 2.32.2) were not met:
Where do I find suitable ones for Ubuntu? (any tips for a beginner welcome)

What are you trying to do? On which system are you and what version of
evolution are you trying to build?
Ubuntu 10.10 has 2.30.3.   I'd like 2.32.whatever 

Default version of evolution on ubuntu maverick (10.10) is still 2.30,
as far as I know. The error in the above configure stems from the
missing libraries, which your custom build of evolution-data-server and
evolution are going to install. Have you followed my advice in the
messages below. Install into a fresh directory like /opt/evo and
specify PKG_CONFIG_PATH=/opt/evo/lib/pkgconfig environment variable when
doing the build. Then it should pick up the correct, latest libraries.
First, build gtkhtml, then evolution-data-server, then evolution. 

Remember having responded to you last November:
Yes, I still have those. Paul's makefile didn't get me anywhere. But
the suggestions from Thomas did, so I'd like to continue along that
It states there that you can do a
sudo apt-get build-dep evolution to get the needed build dependencies
for evolution installed.
This does not bring in the versions that evo 2.32. needs 

He seems to be trying to build a newer version than is available for his
version of Ubuntu. Which of course wouldn't work because various
libraries are not up-to-date (they're probably still at 2.30 or 2.28, no
idea where Ubuntu 10.04 is stuck at currently).
Thats right.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]