Re: [Evolution] Cannot empty trash

Let's try a little role-play... You, the developer, have created a GUI app that regularly corrupts its own index files. You have been told about the bug some time ago and done some research, now you have turned up to a meeting with your PM claiming to have fixed it.

PM: "OK what's the fix?
Developer: "The user has to open a terminal and delete all these files called ~.xyzblahblah* every time it happens"
PM: "You're not listening. That's a workaround, not a fix. You can't ask GUI users to run around rm'ing things! So when will you have it fixed?
Developer: "But it is fixed."
PM: "You're still not listening! What agency are you from?"
Developer: "But... it's easy - all they need to do is..."
PM: "Look, the files called ~.xyzblahblah* don't even exist in the current version, so you don't even have a workaround, let alone a fix. What agency?"
Developer: "But..."
PM: "FRIDAY, 5pm, no workarounds - a FIX!"


On Mon, 2009-11-16 at 10:25 +0000, Pete Biggs wrote:
On Sat, 2009-11-14 at 10:36 -0600, Clarke wrote:
> I keep trying to empty my trash folder, and the option to delete
> individual mails is greyed out.  I get an error that says, "Error
> while expunging folder."  "Summary and folder mismatch, even after a
> sync."  I have seen a lot of webpages that reference this error, but
> none that provide a straight answer of how to finish.  They point to a
> bunch of files that I can't fine (beginning with a tilde).

A tilde in a path just means your home directory - it's standard Unix
shell notation.  So ~/.evolution means the directory .evolution in your
home directory - if you do 'cd ~/.evolution' it will take you to the
correct place.

The definitive answer to your query is in the Evolution FAQ,
specifically at

(Can we not put the location of the FAQ in the mailing list sig - it
seems that at the moment many of the questions here can be answered by
looking in the FAQ)

>   How do I find these files, and if deleting them is not the answer,
> does anyone know of how to remedy this? 

Depends on what the problem is.  If deleting the index files doesn't
work, then run Evo with debugging turned on and post the relevant bits
here, someone will probably be able to tell you what the issue is.


Evolution-list mailing list
Evolution-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]