Re: [gnome-desktop-testing] setting a queryEditableText


The problem is that the Nautilus Icon View seems to have a11y broken (I
will look up for a bug or file a new one in case I can't find it).

How to check that it is not working correctly:

Accerciser has a GREAT feature which is searching in the a11y tree the
element under the mouse cursor. If you have accerciser running, and, in
any other accessible application you type Ctrl+Shift+?, Accerciser will
search that element in the tree.

If you do that in Nautilus, and you place your mouse under one of the
icons, it finds a different icon in the tree.

In fact, if using the same code you wrote, instead of doing:


you do:


it returns a complete different value.

You can also confirm this running orca (screen reader), the Icon View
has a bug in the a11y information.

You can still create your test, but you will need use the List View
instead, which seems to be working correctly.

I hope this helps.

On 05/27/2010 04:54 AM, James Tatum wrote:
> Hi Leo,
> Oops. I reread your original email and I sure enough misunderstood what
> you were trying to accomplish.
> This one is really strange. Accerciser is sometimes able to edit the
> field and sometimes not. But it's possible there is an LDTP bug here as
> well. txtuntitledfolder should indeed be the editable text field, but on
> my system calling gettextvalue on txtuntitledfolder returns the name of
> the first folder in the window, not 'untitled folder'. So it definitely
> seems like something is going on there. I'm still not terribly clear on
> how to debug the LDTP internals enough to see what's going on with that.
> Nagappan, do you have any ideas on how to proceed?
> I also took a look at selecting a file. The items are represented via
> their icons in accerciser and ldtp, so icoitemname is the folder. This
> seems to be of limited utility though. Using getallstates, you can see
> that icons are selectable and focusable, and when highlighted in Naut
> they are also both selected and focused. What I don't see in accerciser
> is an accessibility action for clicking, selecting or focusing. So there
> may not be an a11y interface for doing that. There is an interface for
> accessing the context menu and it seems that ldtp1 also had this in
> terms of the ldtp.rightclick() function. Somehow this doesn't seem to be
> present in ldtp2. There are also the mouse* functions: mousemove,
> mouseleftclick and mouserightclick that should help, but also seem to be
> broken - at least on my system and in this context.
> On Wed, May 26, 2010 at 9:40 PM, Leo Arias F. <yo elopio net
> <mailto:yo elopio net>> wrote:
>     Hi James,
>     Thanks for the answer.
>     On 05/26/2010 07:10 PM, James Tatum wrote:
>     > So as far as writing a test, you'd have to set focus to the icon,
>     press F2
>     > or pick Rename... from the context menu, then getchild on the parent
>     > container to get the edit box. Hope that makes sense.
>     >
>     > On Wed, May 26, 2010 at 2:53 PM, Leo Arias F. <yo elopio net
>     <mailto:yo elopio net>> wrote:
>     It makes more or less sense (I don't know if that's the right expression
>     in English :) )
>     I'm adding a new folder. So before trying to edit the name, I click on
>     the menu File > Create Folder.
>     Then, the name of the folder is editable. And I think that with
>     'frm*untitledfolder' I'm selecting the text field, not the icon. I might
>     be wrong here, of course.
>     To make it even more weird, I've just tried to reproduce this again with
>     mago, and now the error displayed is that the child was not found :S.
>     Anyway, I'll try to spot my mago error later. Now I still can reproduce
>     this on the python interpreter.
>     Please tell me if following this steps you can rename the folder without
>     issues:
>     - Open nautilus
>     - Go to File > Create Folder
>     - Launch a python console on a terminal
>     - Enter the follwing script:
>     -> import ooldtp
>     -> nautilus = ooldtp.context('frm*FileBrowser')
>     -> textfield = nautilus.getchild('txtuntitledfolder*')
>     -> textfield.settextvalue('test')
>     Perhaps I'm missing something...
>     Oh, and in order to try with the f2 key, could you please tell me how to
>     set the focus to the icon?
>     thanks a lot.
>     pura vida.
>     --
>     ︾az y baile!
> _______________________________________________
> desktop-testing-list mailing list
> desktop-testing-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]