Re: [gnome-desktop-testing] A couple of comments


There are different subjects that have been discussed in this thread so I would like to summarize them to avoid any confussion:

1.- Renaming methods for more coherent interface
  - "open_and_check" to "open"
  - "exit" to "close"

I think that nobody had any concern on this so, given that it's not a big change, I may commit it directly to the main branch. Do you agree?

2.- Adding regression tag to make it possible to include several test suites in one xml file

It isn't yet clear how useful would it be this change so we can defer this discussion for the future.

3.- Creating TestSuite class and make all test suites inherit from it instead of from an application class

I think we basically agree on this being a useful change since this design would make it possible to have multiple applications per test suite instead of having to inherit from a single application class.

Best regards,

Ara Pulido wrote:

Tis conversation makes me think that there isn't a clear difference in the framework about what is a test suite and what is an application. In fact, the test suites are being implemented as application classes. Maybe we could define some kind of main TestSuite class to make it clearer what are the attributes and methods of a test suite (i.e. setup and teardown) and make the test suite inherit from that main TestSuite class and contain one application object instead of making the test suites inherit from an application class. What do you think about this change in the class structure?

I like it, but I would like to favor the scenario where a TestSuite
contains several applications, not just one.

I still believe that a regression suite is just a type of test suite,
but I agree that the current implementation does not allow it.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]