[gnome-desktop-testing] A couple of comments

Hello all,

I'm writing to the group just to know your opinion regarding a couple of
comments that I have:

- open/exit: Two of the most used methods in the Application class are
open_and_check and exit. I believe that maybe open_and_check should be
renamed to open since the _and_check suffix maybe is redundant in a test
suite environment. It's not a big change, but I think it eases API usage
for future testers. I know that there are some classes that implement
their own open method based on the open_and_check method, but I'm sure
that won't be any problem since the Application.open method be still

In addition to this, the exit method maybe should be renamed to close
because it seems its aim is to perform the opposite as open so the API
will look more coherent if we use antonyms for these method names.

- xml file format: As some of you know, I would prefer to write the
whole information regarding test suites and test cases in the source
files instead of in separate xml files to have all the information in
one place. However, given that xml file support is already in place,
maybe we could try to extend it to make it possible to provide
additional features that now can only be used by passing command-line
arguments to the ubuntu-desktop-test runner. For example, I have been
thinking in adding a way to define a whole regression in one xml file.
That change will only need the ability to add multiple suites to the
same xml file, that is, instead of:

maybe something like this:

Probably this isn't really useful now, but it might be in the future.

Best regards,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]