Re: Beagle 0.0.12 Filesystemindex not working

On Wed, 2005-08-10 at 14:25 +0100, Daniel Drake wrote:
> Hi,
> Sharninder wrote:
> > Following up on the above email. I upgraded to kernel 2.6.12 with the
> > inotify 0.23 patch and deleted the old indexes under ~/.beagle. Even now
> > I can't get beagle to index my files. But it looks like I have another
> > problem now. Every 1-2 minutes, the hard disk goes bananas with a lot of
> > disk access and I can't do anything since the CPU is busy doing the HDD
> > Access. I ran 'top' and found out the culprit is mono. Is this a known
> > problem too ?
> At startup, beagle has to iterate over the entire home directory and any other 
> roots you have specified. This is an expensive operation, and some users 
> reported it taking 5-10 minutes for large directory structures.
> It would help if you were to post some logs.
> In the CVS version, this expense is now almost zero:

I read that email but was'nt feeling adventurous enough to try the CVS
version, so I decided to go with the released version. I'll leave the
machine overnight and see if I still have this problem tomorrow. I ran
beagled in debug mode (doh !!) and figured out that the fileindex
backend wanted sqlite to run. I don't know why this is the case when I
have extended attributes (user_xattr) enabled for my /home. So now with
sqlite installed beagle is indexing my home directory but I can't search
my mp3 collection using best. Probably it has'nt yet indexed the
complete collection.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]