Re: [Patch] Enable multi-threaded POP3 retrieval

On 2018.01.06 14:55, Albrecht Dreß wrote:
Am 06.01.18 20:15 schrieb(en) Jack:
Just say “rm libbalsa/libbalsa-marshal.[hc]”, and then again try “make”. Then these files should be re-generated properly.

Unfortunately, that gives the same error. However, there is a .h, .c, and .o. The .c does not seem to get regenerated, but the other two do. Is that relevant?

Ooops, actually, you should also remove the '.o' file before running “make” (i.e. “rm libbalsa/libbalsa-marshal.[hco]”). None of these files is in git, they are *all* created by parsing libbalsa/libbalsa-marshal.list and by the build process, respectively (maybe a “make clean” before “make” would work, too). This file should contain, inter alia


The first is the new mashaller, the second the old one.

Still not. In the source tree, in ./libbalsa/ there is also libbalsa-marshal.h anc .c. These are both explicitly listed in .gitignore. When I deleted them, then any make gives me

make[3]: *** No rule to make target '../../balsa-git/libbalsa/libbalsa-marshal.c', needed by 'libbalsa-marshal.o'. Stop.

At this point, I'm wondering if they were there from some past attempt to do an in-source build. However, "git checkout -f master" left me with the same problem, and I thought that would get rid of any files not in the original checkout. Should I do a new clone?

Anyway, just to see what happens, I copied libbalsa-marshal.c from the build libbalsa to the source libbalsa, and then make completed. It runs, so maybe that gives a hint about what's still funny.

I'll talk about the results in the other thread.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]