Re: [Patch] Enable multi-threaded POP3 retrieval

On 2018.01.06 13:36, Albrecht Dreß wrote:
Hi Jack:

Thanks in advance for testing!

Am 06.01.18 19:32 schrieb(en) Jack:
Thanks for the patch--that was a lot of effort! It builds and runs for me, and shows progress for my one POP3 host; I can't easily test with multiple hosts, so I pushed it to master for others to test.
But you didn't test the meson build, did you? :-)  I get

No… :-/

Meson encountered an error in file src/, line 107, column 0:
File threads.h does not exist.

Hopefully I'll be able to figure out the syntax to remove the reference, without breaking anything else.

Does this patch help:

diff --git a/src/ b/src/
index a783fbd..b9f72bd 100644
--- a/src/
+++ b/src/
@@ -64,7 +64,6 @@ balsa_base_srclist = [
-  'threads.h',

My next move was to delete that line (which is line 65, even though the error said line 105) but it failed on something else. I tried the standard autotools build and got (I think the same) failure:
  CC       mailbox.o
../../balsa-git/libbalsa/mailbox.c: In function 'libbalsa_mailbox_class_init': ../../balsa-git/libbalsa/mailbox.c:197:22: error: 'libbalsa_VOID__INT_DOUBLE_STRING' undeclared (first use in this function)
                      libbalsa_VOID__INT_DOUBLE_STRING, G_TYPE_NONE,
/home/jack/balsa/build/../balsa-git/libbalsa/mailbox.c:197:22: note: each undeclared identifier is reported only once for each function it appears in

I tried once more with a completely empty build dir, but got the same result.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]