Re: [Patch] Enable multi-threaded POP3 retrieval

On 2018.01.06 13:55, Albrecht Dreß wrote:
Hi Jack:

Am 06.01.18 19:44 schrieb(en) Jack:
My next move was to delete that line (which is line 65, even though the error said line 105) but it failed on something else. I tried the standard autotools build and got (I think the same) failure:
  CC       mailbox.o
../../balsa-git/libbalsa/mailbox.c: In function 'libbalsa_mailbox_class_init': ../../balsa-git/libbalsa/mailbox.c:197:22: error: 'libbalsa_VOID__INT_DOUBLE_STRING' undeclared (first use in this function)
                      libbalsa_VOID__INT_DOUBLE_STRING, G_TYPE_NONE,
/home/jack/balsa/build/../balsa-git/libbalsa/mailbox.c:197:22: note: each undeclared identifier is reported only once for each function it appears in

I tried once more with a completely empty build dir, but got the same result.

Hmmm, the marshallers changed – looks like a broken dependency in the Makefile…

Just say “rm libbalsa/libbalsa-marshal.[hc]”, and then again try “make”. Then these files should be re-generated properly.

Unfortunately, that gives the same error. However, there is a .h, .c, and .o. The .c does not seem to get regenerated, but the other two do. Is that relevant?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]