Re: [Patch] Enable multi-threaded POP3 retrieval

On 2018.01.06 15:28, Peter Bloomfield wrote:
Hash: SHA1

Hi Jack and Albrecht:

On 01/06/2018 02:55:32 PM Sat, Albrecht Dreß wrote:
Am 06.01.18 20:15 schrieb(en) Jack:
Just say “rm libbalsa/libbalsa-marshal.[hc]”, and then again try “make”. Then these files should be re-generated properly.

Unfortunately, that gives the same error. However, there is a .h, .c, and .o. The .c does not seem to get regenerated, but the other two do. Is that relevant?

Ooops, actually, you should also remove the '.o' file before running “make” (i.e. “rm libbalsa/libbalsa-marshal.[hco]”). None of these files is in git, they are *all* created by parsing libbalsa/libbalsa-marshal.list and by the build process, respectively (maybe a “make clean” before “make” would work, too) This file should contain, inter alia


The first is the new mashaller, the second the old one.

Hope this helps,

Sorry about the meson build--no, as you can tell, I didn't test it!

Albrecht's patch fixed it for me. I had to scrap a previous build directory because of a meson upgrade, so I started with a new one, and ninja ran with no errors. I'd previously tested the autotools build, and that too was clean for me.

Generating those marshal files is messy in the meson build. Recent glib ('>= 2.53.4') has a new glib-genmarshal which makes it easy, but the older one had to be tricked into producing working files. What is your glib version?
I'm on 2.50.3, and have 2.52.3 also available. I might be able to try 2.53 or 2.54, but they are just not yet packaged for Gentoo.


balsa-list mailing list
balsa-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]